Can't connect to RoboRio

we can connect via USB and we can ping via USB and upload but we arnt getting any communication. it all works fine but the driver station connecting. in diagnostics its list our roborio. we have updated all the firmware and java and everything is up to date. we have disabled firewall and run it as administrator. we were also testing with 2 computers and bot worked with USB for uploading and pinging. yet neither will show connected in the driver station. we have reset our roborio and installed everything from scratch and it still isn’t working. if anyone knows whats wrong or can help us connect to it; it would be greatly appreciated.


Are both the Communications and the Robot Code lights red on the Driver Station?
A green Communications light means the FRC Communications task on the roboRIO is talking.
A green Robot Code light means your code is up and running and hasn’t crashed, but it won’t be green if the Communications light is green (a partially green light is okay too).

While able to ping, go to the Driver Station Diagnostics tab to see if the ping lights there are green for the Robot (unless that’s what you meant by “in diagnostics its list our roborio.”).

Then go to the Setup tab and next to where it says Team Number and verify that 5725 is entered there.
Beside the Team Number click on the downward arrow to see if anything is listed there.

Do you see any error messages or warnings listed in the Driver Station message window?

after flashing it the forth time it worked. idk what was wrong with it but it now works.

Try turning off the firewall on the PC running the driver station.