Can't connect to the robot

Hello everyone !
my team got a new programming leptop for this year, we got labVIEW set-up and everything on the computer, but i can’t get the communication light on the driver station to be green (only red…)(using Wi-Fi), the problem isn’t the roboRIO itself because i can connect from every another computer i try…

when i try netstat command on the cmd, the computer did find the ip of the robot, 169.254.175.10, but i when i ping that ip or roboRIO-1577-FRC.local, i am getting:

when pinging 169.254.175.10:
Reply from 169.254.66.43: Destination host unreachable (x4 times)

when pinging roboRIO-1577-FRC.local, it just says it could not find the host…

another funny thing is, when trying to connect using ethernet cable diractly from the computer to the roboRIO, everything work just fine
(the usb port of the roboRIO is unreachable, don’t ask… but i guss it will also work just fine like the ethernet cable)

any ideas ?

I am unsure about your ethernet issue, as I have not dug into the new radio setup (which uses 10.x.x.x, and I don’t want to change my laptop from 192.x.x.x). I am testing with just an old router in place of the radio and it works fine.

However, USB should work – connect a usb cable and disconnect the radio cable. In a browser (with SilverLight added) and go to 172.22.11.2 to get to roboRIO-(team-number)-FRC Sys Config page. Driverstation also works over usb, I believe, for tethered tests.

gil

that is the thing, using ethernet cable it works fine, usb should work also …
my problem is, when connecting to the roboRIO using Wi-Fi, i cant get communication on the driverstation …

I assume your PC wireless connects to the robot AP just fine.

Try disabling the Windows firewall and any anti-virus you may have running. Those can block the FRC handshake depending on how the connection is treated (Private, etc).

First thing to check if the IP address of the Programming Laptop is: 169.254.175.xxx. If not, you will have trouble.

Is the IP Address of the Programming Laptop: 169.254.66.xxx? Why is Ping returning 169.254.66.43 if you asked for 169.254.175.10?

I am not a fan of mDNS. I prefer to give everything a valid IP address.

Use IPCONFIG from the CMD box to find out your IP Address.

I have seen a possibly related problem where the radio sets a frc-robot.local domain on all DHCP clients. This causes pings to the roborio-xxxx-frc.local address to fail and the driver station will not connect. I flashed the ac radio with th 17.2 version of the radio configuration tool. There is no way to configure the domain on it.

I’m still tracking down the issue.

That second IP address would be the IP of his computer.

The problem I am seeing is you are getting and APIPA address. Do you have the Ethernet cable directly connected from your laptop to the roboRIO? You should make sure that your openmesh radio is imaged and configured for you team.

It would eventually be a problem if the first 3 numbers in the IP address did not match.

Where you able to solve this?
We seem to be having the same problem with the wifi connection. We can connect through the radio by ethernet cable, but not by wifi.

When connected by wifi, we can ping the roborio by ip address (10.xx.xx.21) but not by name (roborio-xxxx-frc.local). The driver connection cannot connect however. It seems to be a problem with name resolution.

So our solution to the name resolution problem was to install Apple Bonjour (part of iTunes). Bonjour is a working implementation of mDNS for Windows.

I asked another mentor who works for Microsoft to check and see if Microsoft was working on any fixes related to mDNS and as of right now it is not a high priority for their development team.

Sorry, if I’m starting with too simple a solution, but just a hunch:

The radio Ethernet port furthest from the power input is used for connecting to your computer. The Ethernet port adjacent to the power input is for connecting to the roborio.

Also, it’s important to know that the radio power must come from the 12 volt/2 amp outputs of the VRM. (Different than previous years)

We’re having the same problem.

When we log in to the roboRio over the USB, the IP address says 0.0.0.0.

We can’t log into the router to get the IP or see what’s going on because the web interface no longer works.

We ran the radio config utility and same issue.

Old radio works fine.

Bumping because we’d like to be able to control the robot without needing the USB cable plugged in.

We installe iTunes and it didn’t help.

Other ideas? Thanks!

If (1) the roboRIO is connected to the radio by Ethernet, and (2) you connect at the same time via USB and browse to the roboRIO webserver, and (3) the Ethernet address is 0.0.0.0, then the radio is not providing an IP address.
That usually means that the roboRIO is not detecting anything connected to the Ethernet connection.

Does the Ethernet connection on the roboRIO light up with the yellow & green status lights?

Is the roboRIO Ethernet connector plugged into the radio port closest to the power connector?

Thanks. The 0.0.0.0 was a bad ethernet cable. We got it to connect.

However, on the driver station, we have to enter the IP address of the RoboRio rather than the team number to get it to connect, and the same with the webcam.

roborio-2723-frc.local address is not recognize on the laptop, and since the IP address changes sometimes there is no guarantee we can guess the correct one. Seems like a laptop networking issue, but we’re not sure how to solve it.

It’d be so much easier if you’d tell us what troubleshooting steps you have taken.
What other directions suggested in this thread and others have you followed?

  • Does last year’s radio still work as you said before?

  • Turn off all firewalls, anti-virus, and third party network management software on your PC. Those all can block communications depending on how they were configured.

  • Disable all other network connections (Disable not unplug)

  • You can also try pinging roborio-6026-frc.local, roborio-6026-frc.lan, roborio-6026-frc.frc-robot.local

We were having very similar problems as described in the first post in this thread. This fixed it:

  1. Open a cmd window as admin.
  2. Type: netsh int ip reset c:\resetlog.txt and press enter
  3. Restart your computer

Hope this works for anyone looking for a solution to this.

Sorry, I should have said that we looked at the WPI troubleshooting here: For the 2020 season software documentation has been moved to https://docs.wpilib.org. Documentation for KOP items can still be found here. | FRC KOP Documentation

as well as trying the other suggestions on this thread.

After your response, we tried a “ping roborio-2723-frc.lan” (did not work, couldn’t find IP) “ping roborio-2723-frc.local” (also failed) and “ping roborio-2723-frc.frc-robot.local” (which got a response).

There is no firewall running. It seems that the DNS name is getting assigned incorrectly or not at all by the router, but I’m not a networking expert so I’ve no idea. Hopefully we can try again with the old radio in the next couple of days to compare results more closely.

This worked… for about 5 seconds before the driver station lost connection again. “ping roborio-2723-frc.local” continued to work after this, though, at least until we restarted the RoboRio to try to get the connection back. When we reconnected after the reboot, that address failed again.

Entering the IP address in the driver station in place of the team number seems to work, but, like I said, it’s kind of a guess. It usually comes up as 10.27.23.21 but not always.

Thanks for the suggestions.

Since it works, you can type * roborio-2723-frc.frc-robot.local *into the Driver Station in place of the team number. That should keep you connected.

There does appear to be an oddity in the construction of the roboRIO DNS name on some setups where it throws that extra *frc-robot *into the mix.

It really disrupts Java/C++ downloads which check a variety of addresses to connect, but not that extra *frc-robot *address.
Then you have to add that extra address to the list it checks.

Thanks Mark! This is the condition we’ve been struggling with.It’s great to know someone understands the problem; a solution is sure to follow. No pressure. :slight_smile:

The “what do we do meanwhile” bottom line appears to be:

  1. The DS won’t connect. The workaround you gave handles this.
  2. Cannot deploy from Eclipse. Direct connection via USB works around this. Back to the old IFI days.