Can't control spark max through spark max client

Hi. This year, our team decided to try out using the brushless NEO motors on our robot’s drive base. along with this, we also bought some spark max motor controllers to go with it. When we wired it up initially, everything worked fine and controlled how expected. Now, we have run into some unexpected problems.

  1. one of the spark maxes has a sensor fault that never seems to go away.
  2. none of the spark maxes can be controlled through the run tab anymore. When running in percent mode, they continue to blink purple and blank.
  3. when driving the robot in the driver operated period, the controllers on the left side of the robot no longer connect (purple blinking led)

All of the spark maxes are still connected together with a CAN bus because they still all show up in the spark max client. All controllers were updated to the latest 1.5.2 firmware version but the problems listed above persisted…

You can try loading the firmware again. That fixed a similar issue once for me.

Can you verify the sensor cable is plugged in all the way and that the sensor type is ‘Hall Effect’ in the client.

Note that when plugged in through CAN to the roboRIO they will not run.

Can you verify through the client that the CAN IDs match what you expect from your code?

Since you can see all devices on the Network tab of the UI, you can plug into one MAX on your robot to verify all of the above.

The circuit was left running an hour after this post… no code or wiring was change, however, most of the problems have been resolved… The problem of not being able to control the spark maxes through the client has not however. It has been verified that the can ids in the code match the can ids of the motor controllers.

I tried unplugging one of the motor controllers and running it via usb with no CAN to the roborio. Same issue. Blinking purple leds when run is hit

Note that if it has seen the roboRIO at any point since powering up, it will not run unless it receives the enable signal from the roboRIO. You need to completely depower the Spark Max, ensure it is not on a CAN bus with the roboRIO, then apply power to control it over USB.

Thank you! that fixed it