Can't Create HERO project in Visual Studio

Hi guys,

I’ve just started working with a HERO board, and I can’t seem to make a project. It gives me this error every time I follow the instructions.

After doing some research, I realized that it says it’s missing the Micro Framework. I don’t know how this is possible, as it is installed on my machine.

I’m using Visual Studios 2019.

Any tips or solutions would be greatly appreciated!

That error does mean that the netmf plugin is missing in visual studio. This can sometimes happen when Visual Studio has updated, or rarely because the plug-in didn’t install correctly.

You can either re-run the Phoenix installer or manually run the .vsix file to re-install the plugin.
If you want to run it manually it should be located here on your PC:

C:\Users\Public\Documents\Cross The Road Electronics\HERO\Visual Studio Plugin\NetmfVS16.vsix

I manually installed the .vsix file and it worked. Thanks a bunch!

@Jacob_C Actually, while I have the thread, could you also explain what might be causing the board to output the following when I run “Start”?

Thanks so much!

It looks like you’re missing a library reference. The default project for Arcade Drive doesn’t have this issue, so it’s likely code you added (if that helps narrow it down).

Is there something specific you’re using Microsoft.SPOT.Net for? If not you can remove it, it looks like that’s the library that needs the missing functions.

@Jacob_C I haven’t added any code, although I did remove the print statements which used the Microsoft.SPOT because it doesn’t get that reference. Is this is? And if so, how should I install it?

I got the exact same error after removing those references.

Oh shoot I deleted the core library. Lemme look at that haha

Your references should look like this:


You will definitely need the two Microsoft.SPOT references and mscorlib. I was specifically referring to Microsoft.SPOT.NET as unnecessary.

So I would do the following:

  • Re-add the references to match the image above

  • Do a clean and then build (under the “Build” menu at the top). It’s possible this will resolve the issue if it’s a problem with caching a previous build.

  • If you are still unable to build & deploy, then double-check that Visual Studio has support for .NET desktop development installed - this is necessary for HERO development because of C# dependencies. You can check this by opening the Visual Studio Installer on your PC and then select “Modify” for VS 2019. If .NET desktop development is not selected, select it and then click “modify” in the bottom-right corner. You may or may not need to re-install the .netmf vsix file after doing this, I’m not sure if it will be affected.

@Jacob_C I started by doing a completely new project with the arcade drive template. I haven’t changed the code. All of the references are the same and working, I did a clean and then a build on the project, and then hit “Start”. It complained about its connection so I fixed that, and then it gave me the exact same thing. I do have .NET desktop support on, so I’m a little lost. Do I need to reimage the HERO?

Edit: tried reimaging, didn’t work. I do see two images, am using the broadcast one. Is that the right one?

You should be using any HERO firmware that says “netmf”, which includes the one you’re referring to.

Does this issue occur when deploying the basic Simple App as well, or just with Arcade Drive?
Also, what’s the exact version of Visual Studio that you have?

I haven’t been able to reproduce your issue yet, so I’m trying to narrow down what the issue could be.

I really appreciate this spectacular help! Let me check the simple application.

@Jacob_C No, it does not work. Same thing.

Can you send us your Visual Studio configuration? Either attach it here or send us an e-mail to

You can export your config using the Visual Studio Installer. Select “More” → “Export Configuration”.
I can look through it and see if maybe something is missing that isn’t obvious.

Alternatively you could try the nuclear option - I’d like to understand what the issue is, but if you just want to get up and running there’s a chance doing a full uninstall and re-install of Visual Studio and Phoenix may solve the issue, especially if it’s an obscure missing component.

@Jacob_C I just sent you an email with the config. Thanks!

@Jacob_C Importing the config now, received this.

Will this be a problem? I’ll continue around it for now.

That shouldn’t be an issue, it’s not related to the netmf stuff at all.

@Jacob_C Just finished with the modifications, same error. Should I try any specific Phoenix version?

No, any of the recent versions will do. After the uninstall/re-install of Phoenix I also recommend creating a new project to test, just in case.

If that doesn’t work then the last option is the VS re-install.

Strange, why is it finding the SPOT.Net assembly if I’m not using it? I guess I’m reinstalling visual studios now.

There are transitive dependencies that can get deployed, I confirmed this when I was trying to reproduce the issue on my end earlier. So that by itself isn’t concerning.

But if you’re still seeing the original error, then yes I would re-install Visual Studio.

@Jacob_C Finally was able to get back into my buildsite today, tried a different computer, and it worked! However, my HERO tells me the Talon SRXs are too old (needs to be >20) when I use the firmware for the HERO (11.8), but when I load the only ones that are greater than 20, it says it’s incompatible. Tips?

What version of Phoenix do you have installed?

We haven’t distributed non-FRC versions of Talon firmware in quite some time, latest HERO is compatible with the 20.X and 21.X firmware.

You do need to make sure your Talons are not FRC-locked, but error messages will tell you if that’s a problem and then you can unlock them with the Factory Default button in LifeBoat OR by using the physical B/C cal button process.