Can't format roborio with the 2023 image

I’ve been trying to update one of our test bench to the 2023 firmware using the robo rio reimaging tool. It worked fine on our other but this one dosen’t want to go for some reason.
Here is a screenshot of what the window looks like:


I’ve already tried:
running the tool in admin mode
using different computers
using different cables

has anyone had this issue before? How did you fix it?

From Imaging your roboRIO 2 — FIRST Robotics Competition documentation

Imaging the roboRIO 2 directly with the roboRIO Imaging Tool is not supported.

1 Like

Sounds like you may have been surprised by the difference between the RoboRIO 1 vs 2 flashing methods. We hit this same thing a couple days ago. In short, you need to remove the micro SD card and mount it in a card reader so you can copy the image to the micro SD card. Or so we think… We didn’t have a card reader on hand so we’ll try finishing up today.

I followed the steps in documentation above. I flashed the image onto the sd card using balenca etcher, and then I went back to the reimaging tool to apply the team number as it says. When I hit apply it thought for a while before spitting out this error:


I can’t find anything about what this actually means or how to fix it. Do you have any ideas?

You can try using the WPILib RoboRIO Team Number Setter tool instead. If that doesn’t work either, try imaging the SD card again.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.