Can't get AMT absolute encoders to work

#1

So we’re doing swerve for our first time this year, and we bought a couple of AMT 112S encoders to measure the wheels’ azimuth.

To test the encoder we 3D printed a gear with a long shaft which rotates on a bearing attached to the case. It can be seen here:

https://i.postimg.cc/yWjKLTMC/Encoder.jpg](https://postimg.cc/yWjKLTMC)

We used the cable seen on the picture, and based on the datasheet we marked down which wires are what and taped the ones we didn’t need. We plugged in the wires to an Interface Board on top of a Talon SRX we have hooked up to a test board.

We use LED’s on the board to see if we are getting encoder readings, but when we tried spinning the gear, the A and B LED’s on the board didn’t blink. We double checked several times that the wires matched the pins on the datasheet to make sure the wiring was done correctly. We swapped out encoders to see if it was the encoder that was faulty but we still didn’t get any signal.

To test the individual pins (A and B) we made a small circuit with resistors, a power source and an oscilloscope that plugged into the encoder. We still wouldn’t get any voltage oscillations for either pin when we spun the gear.

Does anyone have any experience with these encoders or has had a similar issue? Is there any obvious step that we missed? We are stuck at the moment and don’t know what to do.

Any help is appreciated.

Thanks!

0 Likes

#2

What did you set the PPR to?

0 Likes

#3

I suspect it’s this:

You’ll likely need to configure it over serial before you can use it. I could be wrong because I haven’t worked with these but this seems highly probable.

0 Likes

#4

Sorry, I forgot to mention we did configure it over serial before we used it, we made sure it had the latest firmware and configured it.

0 Likes

#5

We set it to 4096 CPR, so I think that would be 1024 PPR

0 Likes

#6

Cool. Have you tried putting in an email or call to CUI and see if they can help with diagnosing the problem?

0 Likes

#7

Yea, I sent them an email the other day and I am still waiting for a response. I might give them a call when I get the chance.

0 Likes

#8

Is there a reason your using the AMT11 over the simpler AMT10’s? I’ve used those successfully in the past. I’d assume you want the configurable index for your azimuth?

If your getting absolutely nothing on the oscilloscope I’d lean towards some sort of configuration issue.

0 Likes

#9

Yes, we went for it because we we want to use the index pulse.

I’ll go over the configuration again to make sure its properly set up, thanks!

0 Likes

#10

The AMT102/3 have index pulses, FWIW. I’ve used AMT103s several times without issue. Going forward, I would recommend them for simplicity’s sake.

0 Likes