Can't get static ip to work-HELP!!!!!!(need ASAP for tomorrow)

So we are using a onboard windows 8.1 tablet to do vision processing. The tablet sends udp packets to both the roborio, and the driver station. However there is a major issue on the real field, it can’t communicate!

In our pre competition setup it was working all just fine, and on the practice field it also works fine with hostnames(so sending packets to “st-robot” on port 5801 and “roboRIO-1658-FRC.local” on port 5802). however when we are out on the real field the hostnames can’t be resolved so our vision doesn’t work.

We then tried to set everything as a static ip, but here’s the kicker, we can’t reach the roborio once we set its ip to 10.16.58.2. we tried subnet mask 255.0.0.0, 255.255.255.0, filling in the gateway and dns or leaving default. once we set it to static, and power cycle it, it can’t be pinged. HOWEVER, the driver station software itself has all green lights! So even though I can’t ping it from the driver station laptop, the driver station software is still communicating with it…

On the other end, when everything is set to static, I can ping the vision tablet from driver station and vice versa which is half of what we need, but we also need the other half. I can’t ping the roborio from either the vision tablet or driver station, but the driver station software is connected to it… it’s not so important to be able to ping the roborio from the driver station but how can i send udp packets to it from the vision tablet??? dns names don’t resolve and the static ip has no response…

We have been trouble shooting this with CSA, FTA and a few other people pretty much all day from morning until we were dragged out the door. and it cost us the entire day… and tomorrow we have real matches…

PLEASE HELP SOMEONE!!! ANYONE!!!

As stated we were working with the CSA guy the ENTIRE day and once matches were over we worked with the FTA guys for a few hours as well and they were even remotely talking to someone over skype even higher up… still the same issue!!!

Just don’t say to reimage the radio, reconfigure the radio, reimage the roborio, or the like… did that for hours on end already

My team is having very similar problems from what I can tell to you guys. We went through the inspection process and found that we had to update reimage the roborio. We also had the radio configured on the field in preparation for the matches tomorrow. However, since we updated the roborio to the newest versions we have not been able to deploy code. We have tried both ethernet and wireless (both of which usually work for us) in order to connect to the robot, but the driver station is not showing communications with the robot.

Does anybody have any ideas?
Thanks,

I think this might be a little bit of useful information for your problem. https://wpilib.screenstepslive.com/s/4485/m/24193/l/319135-ip-networking-at-the-event

If all other devices are disconnected from the wireless bridge except for the RoboRIO and the Driver station, is the roborio pingable again at its hostname and IP address?

sanelss: I assume all firewalls are off?

Do you know about the hosts file? You can put a hostname and IP address mapping in there and it will always use that IP. That gives you the ability to address things by host name when using static addresses.

On windows the host file is located at
C:\Windows\System32\drivers\etc

For instance, if you set your roborio to an address of 10.16.58.2 then you would add an entry like this in your hosts file:

    10.16.58.2      roboRIO-1658-FRC.local

If you add an entry in there, make sure you and other’s on your team know its in there. It will override that name until removed.

I am not sure about the UDP issue.

Sam, try deploying code over USB, then see if it communicates on the field using wireless.

In the end we got it working with this configuration:

Roborio:
static ip: 10.16.58.2
subnet: 255.255.255.0
gateway: 10.16.58.1
plugged into the AF port of the radio

Driver station laptop:
static ip: 10.16.58.5
subnet: 255.0.0.0
gateway: 10.16.58.1

Vision processing tablet on robot plugged into ethernet switch:
static ip: 10.16.58.6
subnet: 255.255.255.0
gateway: 10.16.58.1

another open port of the Ethernet switch is plugged into the remaining port on the radio.

doing this we can use it on field and off field and always communicate to them with the desired ip addresses.
the tablet talks to the roborio on port 5801 and the driver station on port 5802