Can't list SparkMaxes in 2020 VScode

We recently transferred our code from 2019 VScode to 2020 VScode, and reinstalled the 3rd party libraries needed to use SparkMaxes. Even though we were able to use them in 2019 VScode, the code doesn’t seem to recognize it when we type in “CANSparkMax”. Can someone help?

Try closing and reopening vs code

Remember that libraries are managed on a per-project basis. Did you install the library in your project?

https://docs.wpilib.org/en/latest/docs/software/wpilib-overview/3rd-party-libraries.html#the-mechanism-c-java

We’re still getting the same issue.

Can you elaborate on what exactly you did to transfer from 2019?

We downloaded the 3rd party libraries offline instead, and followed the instructions and it’s working now. Thanks everyone!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.