Can't program Radio with 2020 configuration tool

Hello, I can’t seem to program our radio with the 2020 config tool. We have tried the following:

  • Reprogramming the radio (over 30 times)
  • Using a different laptop
  • Resetting the radio
  • Disabling all other adapters
  • Using a USB to Ethernet adapter

Here are the most common errors we received:
NPF adapter error (as described on doc page)
Could not locate bridge

Thanks

What port on the radio are you connected to?

Is the radio powered up all the way before you attempt to configure it?

What port on the radio are you connected to?

The leftmost port (nearest to the DC in).

Is the radio powered up all the way before you attempt to configure it?

Yes, with a solid power LED.

If you open the network adapter settings on the PC you are trying with, do you see that the only enabled adapter is connected to a device?

Yes, it just says Unidentified Network.

I have never gotten the radio to program using the USB adapter.
Maybe others have had luck, but I always need to use the ethernet port.

I tried with the Ethernet port initially.

Have you tried using the 2019 program with everything else identical (ethernet, laptop, port)?
If it works, then the problem might be in the 2020 software. If it doesn’t, try a new cable?

We have tried multiple ethernet cables already. I believe the 2019 program was originally programmed with one of the laptops we used previously but I can try again.

If you’re still having a problem, try the steps outlined here: https://www.chiefdelphi.com/t/frc-radio-configuration-application-bug-error-finding-npf-device-name-for-adapter-solved/339143

My team had the same problem today, and these steps successfully resolved the issue.

It’s worth noting that the 2020 release of the radio configuration utility actually installs npcap instead of winpcap, much like those steps describe

We had the same issue and figured out that we had a bad adapter and when we tried to use an ethernet cord instead it worked. Just make sure the ethernet cable is in good working condition.

We had this same issue and have followed all of these instructions, however, we still cannot solve the NPF Adapter error. Anyone have any other suggestions?

Perhaps visit another nearby local team to see if they can help you get it programmed?

We just did it on a different laptop. /shrug

Maybe try bringing in a personal laptop or reinstalling Windows if it’s that dire?

We were unable to do it on our brand new school laptops. I used my old personal computer and it worked first time.

Last year I used to have the same problem programming radios. I soon learned that all wifi network adapters have to be disabled from control panel in order for it to properly communicate with the radio.

This did not solve the issue for us, and presumably others.

It looks like there is a problem with many teams’ actual radio this year - I would reccomend using the same control system with the same software and the same computer, just with last years radio. If this works. then you know something is wrong with the radio:

We ran into this error on one of our laptops.

We noticed that it only occurred when attempting to load the device firmware. Clicking the “Configure” button worked successfully.

Setting a static IP address on the ethernet adapter in use seemed to resolve the problem.

Watching the log messages from the radio config utility. It appeared that the step to configure the adapter IP address was not performed when loading firmware, it just immediately tries to communicate with the bridge…

If you have a stock radio (FRC firmware not yet flashed, you’ll may need to set an IP Address in the access points default range; which according to google is likely 192.168.1.X. So something like 192.168.1.10 on your laptops adapter should work (documentation for this thing seems to be hard to come by these days - dead links on openmesh website - its almost like they are an EOL product or something)