Can't reimage cRIO after latest update

We installed the latest updates of Labview, DriverStation, and Netbeans. Of course, when we tried to download a program to the cRIO it told us that we were using v19 and needed v20 (on the cRIO). So we tried to reimage the cRIO with the v20 firmware and can’t. We tried it from two different computers that have the latest updates installed, several different network cables, insured that firewalls were off, etc., etc. We had not had any issue reimaging the cRIO prior to this and had reimaged with the v19 firmware several times successfully. When we bring up the Image utility, it does find the cRIO at just like it should. When we select “Format Controller” and the v20 firmware, it says “Connecting to cRIO” and eventually times out and tells us that the IP can’t be found. This sounds like a firewall issue, but I’m sure that firewalls are off on both laptops and that everything is configured like it was when we could successfully image the cRIO.

Is anyone else having this issue?

Do the PCs have multiple network cards, e.g., wireless.
Those should be disabled while you are attempting to reimage the cRIO.

Yea, we checked that on both laptops 9 or 10 times during the 3 hours we tried to reimage the cRIO.

I’m thinking at this point that we might have to reset the cRIO and restart from scratch.

This happened to us tonight, and it was what Mark said - more than one network. The laptop had a wireless connection that was on, so when it tried to do the image, it went out the wrong connection. Turning the wireless off fixed it. Do ipconfig /all and see if another IP address is listed.

I ran into this problem with the v20 update. If you have the BlackJagSerialBridge plugin installed, uninstall it. It blocks the update for some reason

We had a similar problem. The 2CAN plugin also causes an issue.
If you edit the ni-rt.ini file and remove the reference to either the BlackJag plugin or the 2CAN plugin, then the update may succeed. It took 2 tries after I removed the reference, but then it worked fine.

We got it back, but I had to boot the cRIO in safe mode and reformat it, then reboot in normal mode and do the re-image.

Probably just a coincidence that it happened when trying to image with the latest code.

We tried to change the cRIO from C++ to JAVA. cRIO Image Tool would not connect. Had to edit the ni-rt.ini file to take out the reference to the FRC_BlackJagBridgePlugin.out. We also removed the file from the ni-rt/system folder but I don’t know if that was necessary. Now we can download code but then we wait for the cRIO to reboot. The driver station says its rebooting, but Netbeans does not reconnect. Are we supposed to use the driver station and Netbeans at the same time?