can't run code

I currently have some code on our bot and I wish to put some new code on, but I want to try it first as to not destroy what we have working. In the past, we just clicked the run button and the code would run in the RAM on the robot. When we powered down, the code would be cleared and the old code would resume next time we powered up.

Now when I click run, the DS tells me no code and the robot has no code. I am running the same code as before with very slight changes, so the code should not be an issue. How can I fix this?

I am assuming you are using labview from the run button, Correct? you should put this in the labview subforum to avoid confusion.

I don’t know more than just basic LV, but, are the IP’s and connections fine? and is a DS plugged in with the right Team #? also, is the LV target set correctly? (or whatever that is called)

Sorry I forgot to mention, I’m using windriver workbench. I believe the IP addresses are all set correctly, as I have not changed them. I have the laptop plugged into the DS, plugged into the router and the bot connected to the router. I have also tried connecting the bot directly to the DS, with the laptop still connected to the DS. I have also tried connecting the laptop to the router.

This seems to be either an error putting the code on the robot or an error running the code.

Then I can help
are you entering the entry point correctly with the right options? Right click the correct project, Run kernel task, Run? the target is connected properly, and set as the location to download to? also make sure that the run dialogs Download and Build project tabs contain one entry, your project, with the download, a path, a checked checkbox, an unchecked checkbox, and an option
You should not run when code is downloaded, it may cause errors, so I would Unload the current code (reboot), and run, debug etc, then when you are finished, set the correct project (window prefernces…) and then download.