Can't run robot

I have been attempting to run the robot for a few days now. The code that is on there is working as it ran 5 minutes before the robot stopped running. We have all spark maxs but they run when I connect over usb. When i’m connected I can see the robot on the dashboard. I can see a usb camera while we are connected to the robot, and all electronics are showing good blink codes. Any ideas will be helpful. We have tried redownloading firmware, switching electronics out and still have no improvement. The one big thing I have seen that is wrong is that our cpu usage is at constant 92%.

Try a different laptop?

Can you send us a picture of your Driver Station logfile? I have a feeling it might have something to do with packet loss based on your CPU usage.

To do this:

  1. Press the gear
  2. Click “View Log File”
  3. Find a run that has a long duration and has lots of data
  4. Ideally, you press the little folder and upload the actual log file so we can look at it in detail, but taking a screenshot with Snipping tool and uploading it can work as well

Is the Packet Loss plot being shown? Can you upload the file?

Doing that right now

2019_03_01 07_26_55 Fri.dslog (877.4 KB)


Your RIO CPU is running terribly hard. Can you upload your code? That seems to be the only thing that doesn’t seem right.

The code runs fine it is the same code that has been running for the last week or more.

What RIO image are you on? Are you getting Watchdog Not Fed warnings? Is your Driver Station the correct version?

That log file image seems to show the driver station in disabled mode the whole time. Perhaps some more specifics about what “can’t run” means would help. You seem to be connected to the robot fine. What mode are you enabling in, what input are you providing, what output are you expecting, what output are you seeing instead?

Have you verified that the joysticks are still showing up properly in the USB tab of the Drivers Station, and responding to button presses and axis movement?

1 Like

6.0.0, no watchdog errors, driver station is the latest

The event log also shows no joysticks are being registered

We are pushing data to smart dashboard, also I will put a file of it being enabled and trying to run in 10 minutes

It has motors that run automatically when it first is enabled I posted one where we didn’t enable

Ok. If you could put up your code as well that might help. I know it worked before but it might provide us with further insight into your problem.

I unfortunately can’t post the code


We don’t want to post until after season, just something we do and won’t be posting it sorry