Can't update cRIO

I’ve updated it previously easily but now I get this error:

Unable to complete operation because of unexpected error:
Error 7 occurred at File/Directory Info in>

Possible reason(s):

LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS, and / on Linux. Verify that the path is correct using the command prompt or file explorer.


I tried updating LabVIEW, but it still doesn’t work. This is image v28 for Java. Any help would be appreciated.

hey, were having the same problem. If anyone has the answer please reply!!

That path makes it look like you might have tried updating LabVIEW by running the setup program from inside the .zip file. If that’s the case, extract the files from the .zip first and perform the update again.

I found the issue. I iniitally downloaded and extracted the files on a Linux system onto a flashdrive (since the classmate is not internet configured) so the best solution is to redownload, extract, and upload all on the classmate, even if it means reconfiguring the classmate.