Chairman's Award Submission Page Not Connecting

Hey CD,
My team wanted to make sure I could access the submission page for the chairman’s award, but when I go to my dashboard anc click the awards drop-down. I recieve a pop-up the asks if I understand the definitions of the award to which I can only hit close. I am then redirected to a page that complains about too many redirects. I have tried different browsers and devices. Please help if you can.


I am going to try to call FIRST in the morning.

Just tried internet explorer. No luck.

I cleaned my cookies multiple times. Do you think this is an issue on my part?

Hey, my team had the same issue a few days ago. You should double-check to see if your head mentor has given your FIRST account submission status. I’m not 100% sure how to give that status to an account, but as soon as our mentor did that, our awards lead was able to submit all of the awards that we needed to. Hope this helps!

1 Like

I think you are right. My mentor is contacting our head mentor now. Thanks very much.

Yay it works!

3 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.