Classmate networking issues

In the beginning of the season, we set up our Classmate to communicate wirelessly with the robot, and it worked fine. Last week, we put a password on the router, because it was broadcasting free internet, and it was unacceptable. The DS still worked fine. 2 Meetings ago, I finally updated the dashboard (reinstall). Near the end of the meeting, the crio would have to be re-booted twice to show DS comms, but Windriver could still connect and download. after a few reboots, the DS quit working, and we got a No Comm error. After a reboot of the whole system, It still did not work, so I fiddled around with the networking settings, and was forced to use wired because it was not doing anything. The robot worked with the normal reboot, and video feed was achieved (and other controls of the robot). last meeting, It quit ALL networking capabilities. after 1.5 hours of trying to fix the problem, I just use a different laptop as the DS (wireless too!)

Some facts:
when it first stopped working properly over wireless, I was debugging a remote dashboard connecting to port 1165 to get dashboard data ( (wireshark said that the packets were fine)
the dashboard was getting socket in use exceptions, Even after full system reboots (3 total)
dashboard problems not solved after wired

on the last meeting, I disable all interfaces, firewalls, AntiVirus, and extraneous task icons in Developer
all Interfaces were individually configured, and turned on and off
wireless appeared connected, but all pings of IP’s failed.
when wired, ping of correctly configured IP addresses failed, even router, which it was DIRECTLY connected to.
rebooted 3 times
on DHCP, router table showed no IP belonging to it

Developer laptop (not classmate)
installed DS
ran it
entered team #
ran fine

other points:
got and plugged in new joystick on last meeting that was Identical to a joystick it had had before
all other computers on network connect fine
router is team default+DHCP starting at on both bands+Wireless password

Is there anyone who has had this issue? this (at least the wired) definitely needs to be resolved before competitions

why are you using internet on your router? there is no need for it


The DHCP addresses should start at .10, anything under that is reserved (1 for bridge, 2 for cRio, 4 for router, 5 for DS, 6 for developer. That isn’t important.

Turn off security. You have no reason to have your wifi connected to the internet at all. That seems to be tied to your problem…

We are using the Wireless-N band only to communicate with our cRio radio, then using a standard ethernet cable from the router to the Classmate. Works fine. We never put our DS somewhere our Router isnt so it isn’t that big of a deal to us.

There are many things that should have been tried before assuming a problem with the Classmate.

*Check your subnet mask, it should be, we have had some problems related to that

*Check ping to other things, check ping on Ethernet port

*Don’t kill extraneous tasks, most of them actually have a purpose. In fact, in the FIRST installation all of them except AVG have a purpose. AVG does too, but as long as you don’t use it on the internet you don’t need it.

*Tasks in Developer have no effect on tasks in Driver

*Try reinstalling DS after the mandatory updates. You MUST install the LabVIEW updates, btw. The DS is written in LabVIEW, so it needs the LabVIEW updates.

*Try setting a static IP on the Classmate. If you set a static IP, the DHCP server will not find you in its DHCP table because you never got an IP from it.

we start at 6 so the Dev computer can be DHCP

the Internet is there so we don’t have to change from static to DHCP, and manually re-wire to look for an answer to a question

Tried and the Router is

how do you ping the eth port? (or am I misunderstanding this, and you mean ping through eth port? in that case, I tried)

I killed them after it was not working with the thought it was one of them messing with it.

I ran the DS from dev

I installed Labview2, DS1, Re-DS1

I did, and that worked until last meeting

When you have it start at .6 on DHCP, you usually end up getting people’s iPhones connecting to the router. I would suggest keeping the DHCP IP field after .10. Also, I haven’t looked, but there’s probably a way to forwarding internet only through ethernet, keeping it out of wireless, so you can disable security. You could then switch between networks on the computer without rewiring anything. If it’s just not practical to disable internet over wireless, instead of using security, you could use a VPN (Virtual Private Network) which has a password. This is all handled in software, and so will actually require less hardware dedication from the router and the computer an will pass more data through. It’s also quite a bit more secure. Anyone can log into the network, but only people with the VPN password can get any usable data out of it.

DS should really only be run under the Driver account, not the Developer one. That keeps all of the drivers and background programs where they’re supposed to be. FIRST has set up the Driver account very specially so that all of the necessary programs start and stop when you log in and out. I’m not sure if they’re all enabled for the Developer account. Developer was mainly intended for people to write LabView code on.

I got it working again, but i’m not sure what I did. I reset and fiddled around with the connection properties, and also the router, and it works!