Cmaera semi-running away from light

First off, we did put the camera the opposite way in the instuctions(The right way). When we take a snapshot, the picture is upside down. We have the servos plugged in to the cam and are running it through labview. We did get it to track before when we hooked it up to the bot, but no luck now.

When we hold the light in front of it, it will go up, sort of following it, but never come down. I believe it does the same if we move down. What is going on here? It can’t be code, since we are running from labview.

We had the same exact problem… So I’ll be the one to ask.

Do you have the servos to the PWM outs in the camera board or the PWM01 and PWM02 on the RC?

We had ours plugged into the cam board and had that EXACT problem.

Also, you’re better off just downloading the default code and using that to track. I found it 10 times easier and more effective than labview.

EDIT: Re-read, you DID have it working on the bot before. If you want to use the camera pwm outs for the actual tracking you’d have to change the assignments in the code, I beleive in camera.c, I don’t remember off the top of my head.

Its pluggeded into the cam board

Our team did have the same problem, but we more or less fixed it. This is more of a “check the documentation” problem, but here’s a few things to check.

There are 2 jumpers that can be put into the camera to flip servo outputs.

Lab-view settings are opposite/different than the actual code. What worked in labview hasn’t worked for the robot for us.

there are 2 macros in the tracking.h library that you can inverse. This is what worked for us. They are labled by a comment.

Otherwise, good luck! This is one of the hardest probs you will probably encounter.