CMU code can't find stdio.h

hey all,

I am trying to compile Kevin Watson’s code for the CMU (both the bells and the streamlined give same result), and it cannot locate stdio.h

Error [1027] unable to locate ‘stdio.h’ :confused:

I’m using MPLab 7.20, C18 2.40
anyone had such an error before? any ideas on how to fix it?

thanks, good luck to everybody

Are you really sure you’re using C18 2.40?

-Kevin

no kidding, I am. MPLAB-C18-v2_40-win32.exe name of file, right of the CBOT 2006 CD.

I installed it in its default dir C:\mcc18 etc (MPLab didnt like it in any other location)

any chance this can be caused by the location of MPLab (non default)?

thank you Kevin, and everybody else

You are missing the include file path in your project. It sometimes gets dropped when a project is moved to a new machine or when a new project is created.

In MPLAB
Project -> Build Options -> Project

In the pop-up window look for “Include Path” and set it to
C:\mcc18\h

(or for those of you who didn’t use the default install directory for the compile, then browse to wherever it is)

it worked!

Thank you very much Mark, and good luck