CMUcam setup

I can not get the CMUcam to do what the instructions say it can.

I got my CMUcam hooked to an AT powersupply for a steady supply of power. it turns on and when I use Hyperterminal I get the string from the camera that says “CMUcam2 v1.01 c7”. my port settings are

Port: COM2
Bits per second: 115200
Data bits: 8
Parity: none
Stop bits: 1
Flow control: None

I do not know how to send the “gv” to the CMUcam. but I assume it works and I start the CMUcam2 program and it just says “Looking for Camera…”. If I press any buttons on the GUI it freezes up. I appreciate any help anyone can give me. and I encourage other who have the same problem or something similar to post here with me, or if there is already a post on this, let me know, I did not find one in the search though.

What leg of the AT power supply are you using? If it’s the +5 leg, then you don’t have enough voltage to overcome the drop in the internal regulator. The specs say it wants at least 6V, but I’ve fond that to be marginal as well. It does work, however, when powered directly from one of the 7.2V backup batteries. Also, remember that most switchers like the AT supplies require a minimum load to work properly, so this could be tripping you up as well.

Now if I could get the GUI to run properly, we might be able to make a go of it. If you want to get together on this, I’m down the street at EMU. Give me a shout at Two heads are better than one, and we’ll all benefit if we can make it work. :slight_smile:


Lots of people (myself included) have had trouble running the GUI on slower computers, as has been noted in other threads. I tried a number of the school’s computers (1.0GHz Celeron, I think) with no success. I brought in my own 1.8GHz computer for our programming team, and it worked fine. Since you are getting feedback in Hyperterminal, but not in the GUI, it’s safe to assume that your camera hardware is okay, and that the serial port is correctly configured. I don’t know the specs of the computer you’re working on, but try setting it up on a faster computer, and see if it works there.

remeber that the ttl cable should not be conneced at the same time as the serial cable to the pc,we had that problem for viewng the cam

it still should get power from the pwm port tho.

i could be wrong about which cables goes out, i didnt do it but i did watch

All symptoms of an incorrect Serial Port setup or you have the two serial lines hooked up at once. You can only have either the serial line to your PC or the TTL port on the RC hooked up, not both at the same time.

We had trouble using HyperTerminal to set the serial port and making it stick, so we did it using the Device Manager.

Check the serial port settings from the Device Manager.
I get there under W2K by
right clicking Properties for My Computer or under Control Panels click System,
then Hardware tab,
then Device Manager
select Ports (COM …
double-click Communications Port
then Port Settings
and you know the rest.

Hi all,

Sorry if this is a stupid question, but what is HyperTerminal, and what are its uses?

Sorry to bother you,


Hyperterminal comes standard with Windows and can be found at:
Start -> Programs -> Accessories -> Communications

It can use the serial port on your PC and change the port settings. Typically, Hyperterminal is used as a substitute for the IFI_Loader terminal window for displaying debug output from the RC. It has several advantages, not the least of which is the capability to save debug output. There are some more notes here:

You can’t usually have more than one program running that uses the same serial port, so you can’t run the IFI_Loader terminal window while either the Hyperterminal or the CMU programs are running.

Thanks for the help Mark, I will have to experiment. Something to do tomorrow. Yay!

Thanks again,


What problems are you having with the GUI? I’ve seen it work with the latest version of the JRE installed. It seems to be very picky about lighting conditions for calibration, though.

I am not a big fan of hyperterminal. I once turned an iPaq into an unbootable brick while installing linux due to a hyperterminal crash. I reccomend something else. I personally use linux, but for windows, there is a program “puTTY?” which is reputed to be better than hyperterminal.

PuTTY is generally used for SSH, SSL, RSH, and other remoting stuff. It can’t be used on a serial port (to my knowledge).

I am also having trouble with the camera. I have the camera connected to the TTL-232 adapter, and it pulged into a pwm01. Next we opened the GUI with our hopes high and waited awhile. All that happened was that the camera lights blinked. On the gui it said looking for camera…We have the back-up battery pluged in.


You cannot have the camera plugged into the robot controller via the TTL port at the same time as it is hooked to the computer via the RS-232 DB9 port. Unhook the robot controller connection and hook it up directly to the computer and see if this solves the problem.

If the GUI can still not access the camera connect to it with the listed settings in the manual:
• 115,200 Baud
• 8 Data bits
• 1 Stop bit
• No Parity
• No Flow Control (Not Xon/Xoff or Hardware)
through hyperterminal and type GV followed by enter. This should return a CMUcam2 version string. If this happens, you are connected and the GUI is the problem.

One more thing, rumor has it that First removed the camera code becuase it wasn’t working correctly. Have they put it back up and where can I get it from?

Tonight we experimented with the cmu camers, and suprisinlgy got it wokring. we started with the robot, and hooked everything up par to the instructions. no luck. then i realized one of the foolish chassis people decided to unplug the backup battery instead of pressing the reset button :stuck_out_tongue:

so battery hooked up, check. it worked, we had to change the port settings, but it didnt seem to make a difference. we were able to grab frames, but the servo control is still puzzling. once we get the project enclosure, and assemble it, we will try to calibrate it, then who knows what the result will be.

More later when we can get it fixed, and its time to wrap up for tonight

ok, my computer, which is an amd +2800, I guarantee you it is fast enough, is the only thing hooked the the camera, I am feeding it 12 volts which is in the specifications of the camera.

I get the response but I can not send anything to the camera, I am totally ignorant on using a terminal emulator.

OK. Here is the best thing to do:
Use an EDU controller, or if you do not have that then use the FRC controller. Use a PWM cable to get the power from the controller to the cam. You do not need to set pwmXX = 254 to do this; it is already putting out power. What makes it work is the SIG pin, which in this case you don’t need anyway. So camera is hooked up to any PWM_out you want it to be…Power on the controller and Camera. (Be sure to have the serial cable plugged in as well). Now, turn it on and you will see the LED’s come to life. Now run the GUI, making sure you are setting it to the correct COM number, by the way, Serial is typically COM1 but it varies by computer. Try that out, and PM me if you still need help.

We have our camera up and running but if we don’t have enough lighting and turn on a light we get a funny feed from the camera. The only way we have found to fix this problem is to close the program and relaunch it.

Does anyone know of a different way to fix this and if so what did you do? :confused:

I found the problem, it was the serial cable I was using. thankyou for all the advice though. I also figured out how to configure Hyper Terminal so I can see what i am typing.

Could anyone tell me how they mounted the servo motors to the camera ?