CMUCam2 Demo - File Not Found Error

I have been trying to use the LabView CMUCam2 demo, and when I try to run, it gives me the error:

Error 7 occured at Open File+.viOpen File

I have used the most recent file from this forum, from Jan. 31, 2006, yet it still arrives at this error. Is there anything I can do?

Can you indicate which of the VIs the error is coming from?

What are you trying to do when you get the error?

OK I also noticed when i tried to run the Cmucam2 demo in labview i received the same error “error number 7”. The app i ran was CMUcam2 i set it to the correct port and told it to run after this the error number 7 appeared

Sorry about that, this is a common source of confusion for teams. What we have posted up on ChiefDelphi are “updates” or “patches” to the applications, not the FULL application - this is because the files eventually became too large to attach to messages on ChiefDelphi and we didn’t have permanent storage space elsewhere. You’re supposed to copy the “updates” over the “base” software, thus updating your program.

Here’s what you need to do in order to install the CMUCam software:

  1. Grab the “base” software at NI’s Developer Zone.
  2. Grab the “update” or “patch” attached to the last post in this thread
  3. Uncompress the “base” software into a directory.
  4. Uncompress the “update” into the same directory, overwriting files having the same name.
  5. Enjoy using LabVIEW and the CMUCam2!

Remember, in order to use the CMUCam2 with LabVIEW you have to install NI-VISA so that LabVIEW can access the serial ports. It’s a free download, and I could tell you how to get to it here but I think this post describes NI-VISA and the process pretty well - if you’re not interested in the Robot Modeler software, just skip to NI-VISA for now.

And one more thing, I know it’s going to come up so I’m going to head it off, make sure not to plug the CMUCam2 into the serial port on your computer AND the robot controller, the CMUCam2 can only handle one at a time.


Danny, Thank You So Much!! I really don’t know what would have happened without your help. :slight_smile: We’ll be ready to go in no time now! Thank you again!!

OK So i did everything you said to do however when i double click on the cmucam2 demo.llb then click the it starts loading and a browser comes up and says at the top Find the Control Named “eventvkey.ctl” i have no idea where to find this any help would be good. I didn’t want to reinstall but if i must let me know. i dont see how i could have deleted this file because i wasnt even in thoes subfolders.
Thanks you very much!!!

What’s happening is that it’s looking for the eventvkey.ctl definition file in the following location:

  • C:\Program Files\National Instruments\LabVIEW 8.2\vi.lib\event_ctls.llb\eventvkey.ctl
    Please check to make sure that the file is there (remember the event_ctls.llb is a library, you will have to explore to that library and then double-click on it to see if the eventvkey.ctl file is present within that library. If the file isn’t there, you may have an incomplete or corrupted installation of LabVIEW, and the only thing I could recommend from that is to completely uninstall all National Instruments software and reinstall. Let me know if the file IS there but it still isn’t loading!