CMUCam2 Vision Sensor Testing/Problems

Got camera connected to RC correctly. Performed quick check referring to CMUcam2_fe manual.pdf using HyperTerminal. Instead of getting the correct response on the terminal “CMUcam2 v1.0 c6” I got just a “C:” response.

I then loaded “FRC_CMUCam2.hex” into RC. Repeated above and got correct response (c7 instead of c6).

I have noted that my RC Mode is blinking red (disabled) and that the program state is solid yellow/red (looks orange to me).

Tried running the stand_alone JAVE app to test vision system but I have version 1.3. So, I have just downloaded Java Virtual Machine 1.4 and hope to get it installed soon so I can actually see something on my computer. That’ll be cool.

Any idea on the RC fault lights after loading the above HEX file? The default code this year loads okay. Noticed Kevin’s Navigation program gave me similar faults.


Just a small update. Installed Java VM 1.4.2_06. I still have the solid orange light for “Program State”. The CMUcam2 GUI displays the message “Looking for Camera…”.

I just need to sort out the RC program state and I am sure this will work.


Im having troubles as well.

Does the camera need to be hooked up to the RC in order to work?

Right now I have the power of the camera connected to the EDUbot and the serial post is connected to my computer. The CMUCam2 software cannot find the camera, and I tried opening the port using the default settings in the manual. I am able to send commands to the board, but i get no response. I know my serial port is functioning correctly because I am able to send and recieve commands from the edubot controller?

Any ideas?!

I don’t know what’s wrong really, but the electronics team is having some sort of problem with the camera. I think they want to get a new one.

You need to do these things (our experience).

  1. Get the frc camera code loaded into new RC.
  2. Connect PWM cable between PWM output and power connection on camera card.
  3. Connect PWM cable between TTL-RS232 card and the camera card.
  4. Power up the RC.
  5. Press the Robot Reset button on the OI.

Only power on LED is illuminated. We moved a ‘red’ hat in the view out to 12 feet to make the RED LED come on.

Still experimenting…

We can see an image using the GUI software.

The only connections to the camera unit are the PWM cable from the PWM output to the camera module and the RS-232 from COMM1 on the PC to the camera unit.


I’ve had a LOT of problems getting the GUI to work correctly. Unless I’m on a REALLY fast computer (my P4 XP unit) the the GUI app won’t complete a frame grab. Even the P3/500 was too slow. Anyone else having this problem?

Also, the images look really bad, tinted green, and muted colors. (blue is difficult to identify, and try picking out a green target in a green field!) If I turn the white balance feature on, they look blue. I tried looking at the tracking data, and it had a difficult time following a yellow target on a dark background. I’m really worried about lighting, and how this thing is going to react in the field.


I got the GUI to work on any computer after fiddling with the serial port stuff for a while, but our images all come out yellow, really yellow, and when we turn white balancing on it looks very nice, but we can’t find any colors but green, it syas yellow is too bright, and that red is too dark… it can’t make up its mind, but it tracks the green nicely!

At first I thought it was the serial port, but I can communicate fine in command line mode using Teraterm Pro. But the Java stuff is just plain problematic. I’ve got IE6, and installed the Java runtime from the SUN site, but Java just seems to run extremely slow, even with all the background apps and anti-virus turned off. Even on my P4, the program has problems and crashes a lot. XP, or 98SE, doesn’t seem to matter. I’m stumped!

Steve :confused:

Follow the manual very carefully. They have everything in there, except you have to SEARCH for it, unfortunately. It has information on what your serial port settings and everything should be. Try taking one more look.

We can’t seem to get the camera to track. It seems to get through the calibration OK but when you hit “track” the servos just oscillate and then it sez “Can’t track color”. The servos work fine manually and are connected properly. Next this is to try and reload the firmware in the cam.

Congrats and great job on the progress !!

I have found that when using the GUI to get the calibration values I have to cycle power on the CMUcam2 a lot. Pressing the reset button does not do it.

I am also getting the red error light on the OI when loading the test program(s) in FRC_CMUcam2_rev-3. By the way why are there two projects? Which one should we focus on? What does the DDT version do? Why do they causes errors? :mad: FIRST you can do better.

The camera has potential to give the robot direction. But it is worth the cost? This is turning out to be a bad joke.

“Even a blind squirl finds a nut occationally”, why not a tetra?

Did you update the master code? We got the Code Error light until we updated the master code.


If the connection between the camera and the pc runs kinda slow, changing the bit rate of your comm port might work.
Go to control panel, then go to system, then go to device manager, a list will appear with all ur devices, select the comunication ports and then double click com port 1 or 2 for which ever u r using, in the window that open look for the transfer bit rate and change it to 15200 or something like it, then click ok and that might help.

Sorry if it is a little inaccurate but rite now I’m in my Linux partition and am saying this out of the top of my head.

I started having that problem a couple of days ago. It turned out to be a depleted backup battery. Putting on a freshly charged battery made things work again.

Hey I have some questions regarding the camera:

do we HAVE to use the same paints (colors) as given in the Getting started Manual or is it just to give us an idea? is the camera code configured to find only those colors? has any other team had success without using the exact same colors?

I come from a small funded rookie team :confused: so we want the simplest possible solution, thanks.

We found that the colors prescribed by FIRST work very nicely for some basic tracking, so it’s probably easiest to go out and buy a can of that bright green spray paint.

It is not required to use the same paint for your practice hardware. BUT it is a really good idea to do so. The cameras seem to be quite sensitive to color variations caused not only by variation in the paint but by the lighting as well. In such matters it is best to be as close as possible to the real thing


Any ideas on why all of a sudden we cannot grab a frame? Says grab frame failed. Have all connections right. This use to work at the beginning and then we put a halt to it for a why and when we started it up again…error occurs