Code download stops at FTP step

We have the latest Netbeans (7.1) installed and all the latest updates to the FRC plugins. We have re-imaged the cRIO with the latest Java firmware (v43). We are directly tethered to the cRIO using a crossover cable (tried 2 different ones just to make sure). We also have the latest NI Utilities update.

We were able to load a Java program into the cRIO once from Netbeans and have been unsuccessful since. We have re-imaged the cRIO twice (successfully) since we started having the issue and still no luck. The process looks normal until it gets to the “FTP to” step. The progress bar at the bottom of the screen does the Cylon raider visor thing and bounces back and forth 3 or 4 times, then goes away. At this point the process appears to hang up.

I’m sure this is probably operator error in some form or another, but need some suggestions as to what else I can try. Re-install Netbeans and the NI Utilities?

It seems like I saw this 2 years ago when we first used Java, but I don’t recall what we had to do to fix it.

As always, TIA

Well in the console is there any errors?? If so what are they?

And since you are able to re-image the cRio successfully it has to be either a Netbeans issue or the plugins issue.

After you upgrade the cRIO you have to manually restart it to get the FTP server working.

If that doesn’t work…

Use the re-imaging tool to check the IP of it, and make sure it matches the one in your Driver Station settings and Netbeans plugin settings.

And if that doesn’t work…

Have the Driver Station automatically configure your network settings for you using the “Choose NIC” button.

Also check the firewall settings. If still stuck, please post the output - there are networking details embedded that help debug some issues.

We reinstalled NetBeans and the problem went away. It is working first time, every time now.

Thanks for all the suggestions.