Code messing up

So today we were trying to test some code.

We deployed it to the cRIO from LabView on our computer with no issues.

However we tried to control the robot was it had finished loading and we were getting a “No Robot Code” error.

Any ideas?

Im having issues like this, i can deploy code once then i can’t redeploy again and the code is not functioning correctly

Are you building and running as startup, or just running the code temporarily from Robot Main?

I have a feeling you’re crashing the cRIO. Try to run the code straight from Robot Main and see if it gives you an error of some kind.

Have you been placing all of your hardware from the begin file in the finish file to close the references?

Begin: We opened joysticks, drive motors, and a shooter motor.

Teleop: Tank Drive and a simple control for our shooter

Finish: Closing opened items

So we are deploying straight from robot main. We are direct connecting to the cRIO 8-Slot. Should we try going through the bridge?

Can you answer my previous question? The message you replied to was for ProgrammerMatt.

Sorry bout that…

I’m running it from Robot Main and I’m opening everything.

Should I trying making a real-time app?

No. If it’s dropping like that while running, then you must be doing something really wrong.

Are you referencing a second module of some sort without there being one? Such as Digital Module II? Have you tried reimaging it and formatting the controller?

So we built a an application and it worked. Thanks for the input.