Code Not Responding At All!

Our java code was operating as of the last couple weeks, however something went wrong and now none of our motors are moving, yet the updated code seems to go to the cRIO. For example, I put outputs on the driverstation screen and those get outputed, yet no motor function, our camera just jerks back and forth. I commented everything save for the motor functionality. Hardware wise nothing is wrong (checked, double-checked). Reset the cRIO with firmware 27, and I am definatley getting code onto the robot. Has anyone else had this problem and fixed it?

Check your joysticks are working. We had a similar issue a few days ago where nothing moved on our robot, but after we unplugged the joystick and plugged them back in, everything worked.

We also had the same problem a couple days ago. All we did was try driving on a different laptop and that worked fine. If you don’t have another laptop you might want to consider checking out the usb ports for any issues (like the little black part falling out).

Then there’s that possibilty that you changed something in the code and then forgot you did, maybe making your motors turn in the wrong directions or not at all.

Reset the cRIO with firmware 27???

Unless I am wrong, you are using the firmware with known problems. There is an update using version 28.

We had major problems with ver. 27

That’s odd. We were running just fine with ver27 and wanted to make some code changes, so after installing the latest updates in NetBeans, we received a message that we needed to re-image cRio to v28. After we performed the re-imaging, we uploaded our new code and now nothing works properly. All the relays outputs only turn on the spikes in one direction. And the victor controlling the arm is not getting any signal whatsoever. This all happened at a scrimmage event we were lucky to attend in Bridgewater, NJ. Some top Java minds there where unable to help. So we left the scrimmage after 6 hours without getting our robot off the blocks! Wish we could go back to v27! What gives?

Yeah, there’s been a lot of threads about v28 not working properly. We’re just sticking with v25 until just before the competition in hopes that the latest version will be fixed.