Code suddenly fails to initialize

Suddenly my code will not initialize, after downloading the code (which successfully compiles without any problems) the LEDs all stay the same (blinking orange ligh ton program state, solid orange on rc mode, and red solid on OI code error)

Here are the steps I’ve taken to try to diagnose the problem:

  • Downloading default code - works perfectly fine
  • Redownloading the master code - doesn’t help
  • Uncommenting the printf statement in the User_initialization in user_routines.c saying “IFI 2005 controller initialized” - Nothing shows in the terminal window
  • Adding printf statement at the very top of the user_initialization above everything - Still doesn’t display in terminal window

Since the lights aren’t changing, it would seem like it was a hardware issue since the default code works fine. I haven’t touched anything with initialization code in my code, so it should at least be initializing and if there’s a code problem give a blinking red LED on the rc, not a blinking orange (which is for downloading code). So, the problem makes absolutly no sense to me since it won’t even initialize with this code, yet with default it will… and I’ve made no changes.

Any ideas?

This is the EXACT problem my team was having and we were stummped for 2 days. Finnaly after numerous calls to Innovation First here is what worked. If you can change the computer u are dling the code to the robot with. Reinstall the compiler (we changed to the one that was on the CD FIRST gave us, i don’t believe that it supports the camera, but if you (like us) called it quites on the camera, i would suggest using that compiler). Reinstall the IDE and then try dling the code again. That at least is what worked for us. Please let me know if that works, since we got through this problem I would like to help u guys as much as possible, since we know how much of a pain in the rear it was. :frowning:

We are having the exact same problem. We still had the old compiler installed, so we tried to make the switch, but still no luck. Suggestions? HELP. :frowning:

if it was working before, what did you change?

We didn’t change anything. This is the first time we used this code. My programmer is at a loss. I got on chiefdelphi to try and solve the mystery. He doesn’t know what the master code is. I have downloaded it now per the idea from another thread. What do you think? Should he have used the master code b4 trying to load his code? THx

Yes, download the new master code before downloading any new programs. As far as I can tell, you need to download the new master code before you can download any code compiled with the new compiler. The master code can be found on IFI’s website.

Matt

We have done that now. We are still having problems… any other suggestions? We downloaded the new master code per the instructions. We downloaded our code into the robot. We are still stuck with the IFI error.

When we download the program into the controller. (Now that we have downloaded the master code.) The program returns a green program state LED for about 2 seconds. Then the LED goes red. The RC LED is yellow. PLEASE help. Thanks to everyone who has helped so far.

Mandy

Try downloading the default code and seeing if you still get the red LED. If you don’t, then it’s a problem in your code that you need to fix the programming. If you do, then you’re still having problems with the RC.

Matt

[quote=miketwalker]Suddenly my code will not initialize, after downloading the code (which successfully compiles without any problems) the LEDs all stay the same (blinking orange ligh ton program state, solid orange on rc mode, and red solid on OI code error)

We had the same problem…going through our code…(starting with the default code and building back up), we found that commenting out the “Serial_Driver_Initialize();” in user_initialization() worked. Don’t know why. but it worked!

/* Add any other initialization code here. */

Initialize_Serial_Comms();
Initialize_Encoders();
Initialize_Gyro();
robot_init();
Putdata(&txdata); /* DO NOT CHANGE! */

// Serial_Driver_Initialize();
printf("%s
", strptr); /* Optional - Print initialization message. */

User_Proc_Is_Ready(); /* DO NOT CHANGE! - last line of User_Initialization */
}

Jon Team236[/quote]

are you using modified camera code with the encoder stuff from the nav code or jsut the plain nav code? I had an issue when i copied over the encoder interrupt stuff into the camera code, and it was because you couldnt overwrite/comment out the last part

We are using the modified camera code. We went to a scrimmage today and got some help there… I am not sure what anymore. My programmer is working now. I am going to see what is going on. (33 is a little old for a all nighter. - I am the team leader) Thanks everybody. I will ask more questions later.