Comm / No Comm; Little Consistency

Frequently getting no communications to robot.

Windows 10
Eclipse c++

I’m running all current FRC software versions as far as I could double-check.

It is sporadic, but I can reproduce the following:

-Booting everything up, I get comm fine.
-Power off / on the Robot.
-Reconnect laptop to the robot network
-DS gets no comm
-I can http to both the router and the roboRIO
-I stop / start the DS
-DS gets no comm
-I reboot the laptop
-DS gets comm just fine.

When DS has green comm, If is disconnect the wireless network, then reconnect the network the DS comm stays red.

What’s going on??

Many Thanks

Have you tried turning off the Windows firewall? Also, we switched our roboRio to a static IP to avoid mDNS issues. We put an entry for roboRIO-####-FRC.local into the development pc’s hosts file. (replace #### with your team number). We will probably set our driver station to a static IP too for competition. The static IP was mainly so MAC and Linux computers could connect to it easily.

(I tried turning off Firewalls, no change)

I found the following. The reason I loose comm is because the mDNS fails to resolve.

  • After rebooting laptop I get green comm
  • DS, Eclipse, and Internet Explorer can resolve roboRIO-2637-FRC.local
  • On laptop I disconnect from the robot network.
  • On laptop I retconned to the robot network.
  • At this point roboRIO-2637-FRC.local is not being resolved by Eclipse or Internet Explorer, and I expect that is the problem with the DS.

So it is mDNS?

If you shift-click (or maybe just click) the down arrow next to the team number in the driver’s station, that causes a new mDNS query to go out. See if there is anything listed there when it can’t communicate. It should be all robot names detected on the network.

mDNS has caused issues in the past for us. That’s why we switched to static. We think we know the ramifications of it.

The “click the down arrow” thing had no effect.

In a command window try:
ipconfig /flushdns

Disable IPv6? It’s voodoo, but I’ve seen it help.

Hacked at this for days and could not find a fix for the root cause. I have circumvented this by moving to static IP on the roboRIO.

-Clark

Windows 10 has some non-compliant mDNS behavior.
For other people with Windows 10 installations just Disabling/Enabling the network connection has worked.

Its really weird, the only way we have been able to connect to the new bridge wirelessly is by connecting via usb, wait until we have comms, connect to the bridge wirelessly, then disconnect the USB. Its really strange.

While this is bad advice for computers in general, If you are able to devote a computer to be your driver station…

Disable all automatic updates. Keep non DS specific software off the computer. Disable start up auto loaders for software that is installed on the computer. Only connect to the internet when required to download software or updates. Turn off the firewall. Try disabling the Ethernet adapters you are not using. Don’t let the programmers watch little pony or cat videos on the DS computer.