Command-Based: No Robot Code

Hey everyone, I’m using a command-based bot, as my team has historically, but am having issues with this year’s code.

When I just attempt to start it, or even restart the roboRIO, I get the “No Robot Code” error, and prints only “Launching /home/lvuser/FRCUserProgram”. When I ssh in, the file FRCUserProgram exists, and when I run"/usr/local/frc/bin/netconsole-host /home/lvuser/FRCUserProgram" it simply prints out the same thing as it did on the DS. If I just attempt to run the program itself, I get a segfault, and the lack of gdb/gcc or the ability to connect the bot to the internet (thanks to my school) means that I’m unable to make use a of a debugger.

My code is available here:

For reference, I’m working in Eclipse and building the code on a Windows 8 laptop. Also, the roboRIO is capable of running code, as I put the “Getting Started” project on the bot and it successfully ran. Any help is greatly appreciated!

Have you tried the eclipse remote debugger?

Nope, I wasn’t aware of that, thanks!

because its not called gdb. It is called arm-frc-linux-gnueabi-gdb as it is a cross debugger. Though I would recommend using eclipse as that does all the proper magic for you to call arm-frc-linux-gnueabi-gdb

We were seeing the same behavior in our code. For us, it turned out to be accessing a (NULL) pointer before it was initialized.