Communications are finicky

Hello,

Our robot code can deploy to the robot well. We are also able to connect to the radio and drive the robot. However, when we connect to the radio and enable the robot, every once in a while when we are driving or even disabled, it cuts out communications for a second then comes back. We even tried to tie it directly into the roborio and it still did this. What could cause this and how would I go about fixing it? Is it a software update/code problem or is it more likely to be an electronics issue?

Thanks!

1 Like

What other software is installed on the computer? Inventor in particular is notorious for having a background updater that causes comm dropouts.

1 Like

We do not have inventor on the computer. The only autodesk software on the computer is Synthesis. We do not have any CAD software on our driving computer and the only other software on the computer is the phoenix tuner for talons and eclipse from last year which we no longer use. (Also there is the normal pre-loaded windows apps on the device like calculator, photos, etc.)

@Peter_Johnson

oh and obviously all the software in the most recent frc update suite

@Peter_Johnson
Oh and I forgot Chrome and Edge are on it and Mcafee, although currently we do not have a subscription with Mcafee, so it is not running.

What are the battery levels at? I’ve found that the comms will flicker if the batter gets too low, generally below 12v.

1 Like

It is around 12 v

(we just charged it earlier today and plugged it in for the first time)

Have you tried connecting the ethernet directly into the computer and seeing if comms cut out then? That might help narrow down the issue somewhat.

1 Like

I tried it over the radio and also from the computer to the rio directly by Ethernet…

Another good check is to look at the DS log after reproducing the issue (via USB-tether to rule out network-related root-causes with Eth/WiFi)

Here’s one example of a disable blip we’ve seen - (FPGA-watchdog).

Other example root-causes could be excessive packet drops.

1 Like

What would cause packet drops over an ethernet where the only traffic is between the computer and the rio?

Something goofy in the Ethernet network adapter on the PC, damaged NIC, bad drivers.

I’m not claiming these are the issue.
I am claiming that USB-tether is a good simple baseline method for narrowing down on the root-cause.

If it reproduces with USB, that’s useful.
If it does not reproduce with USB, that is also useful.

1 Like

@ozrien
Ok… I will check to see if it happens over USB.

Also, how do you get to/interpret that chart on the DS Log… I don’t currently see how to get to it in my driver’s station and I don’ know what I should be seeing/looking for in the chart…

FRC Screensteps, general docs:
https://wpilib.screenstepslive.com/s/currentCS/m/driver_station/l/144980-driver-station-log-file-viewer

Press the gear icon in the DS in the right pane => View Log File. I don’t actually see this explained in the screensteps, but I could have missed it.

1 Like

Thanks! I no longer have the robot available to test, as I am no longer at school. I will post the results of using the USB tether on this topic tomorrow after I test it…

@ozrien

Hello again,

I finished the test and with the usb tether, it was still dropping comms… Here is a screenshot of the graph in the DS log file (the errors in the graph are all from not updating differential drive frequently enough and because I had one of the joysticks unplugged from the computer as we use two joysticks and an xbox controller. I had to unplug one of them to do the test with the USB-tether.) I also noticed that as it is supposedly enabled and connected to the robot, the light on the robot is not an evenly blinking. It keeps blinking at an unsteady rate (i think the longer blinks are when it drops comms…) Here is the screenshot of the logfile graph:

Thanks again!

This makes it look like something on the computer is holding up communication on the computer side. Likely a program trying to install updates or something similar. I really can’t recommend enough using a fresh laptop with a clean Windows install for your driver station. You can find recommendations for how to get a suitable laptop for relatively cheap.

In the meanwhile, I suggest going through your task manager’s processes and seeing what’s running in the background.

1 Like

@AriMB We got a new Dell computer for this season with Windows 10… We have very few programs installed on it as mentioned earlier in this topic…

Here are the Specs:

image

are these sufficient? and if not what else could cause my problem on the computer?

thanks…

That computer should be plenty strong. Some program on your computer is blocking the communications, either on purpose or as a side effect of whatever it’s trying to do. Make sure all of your firewalls are turned off (Windows 10 has 3 built-in, plus McAfee that you mentioned earlier). Also go over all of the programs that are installed on the computer (including the ones that came pre-installed) and make sure none of them are causing problems.