Competition Tethering Issue

Our team is competing at the Bayou regional, and we began having strange connection issues towards the end of the day after we connected to the field. We connected to the feild fine, and returned to the pit to push a new version of code, which was also successful. Later, we went to the particle field and we were unable to get commms with the Driver Station, however we were able to ping the D-link, ping the roboRIO, and push code perfectly fine, we were just unable to get any sort of communication via the DS. We tried multiple Ethernet Cables, rebooting the robot, and setting static IP’s on the driver laptop. Any help would be greatly appreciated, and if any more information or clarification is need feel free to let me know

Did you try restarting the driver station? We’ve found that when transitioning between tethered operation and the field we need to restart both the robot and the driver station exe to reliably get a connection.

Another thing to try, which can help when things sometimes just stop working, is to restart the NI mDNS Responder Service from the Services menu in the Windows control panel.

We did try restarting the driver station, but we will try restarting that service later if nothing else seems to help.

A quick way to refresh mDNS is to change the team number in the driver station software to some other number (ex. 1) and then change it back to your team number.

ping the robot and/or flush the arp cache, that worked for us

You could also try the USB tether

You can try enabling/disabling the network adapter.

Another thing to try is to reboot the DS between tethering and competition.

When at the practice field, if we were very patient then things eventually connect with no intervention other than DS software restart.