compile error

We have been getting some help from a new found friend on the programming side. Last night he came to help and was plugging in some auto mode, but got the following error…

Executing: “C:\Program Files\MPLAB IDE\MCHIP_Tools\mpasmwin.exe” /q /p18F8520 “mcmpp2p.asm” /l"mcmpp2p.lst" /e"mcmpp2p.err" /o"mcmpp2p.o" Error[101] C:\MCC18\SRC\STRING\18CXX\MCMPP2P.ASM 102 : ERROR: (No Model Specified) Halting build on first failure as requested. BUILD FAILED: Wed Feb 16 20:43:52 2005

Rookie team 1696, frosh team, volunteer mentor, not a software guy, did spend time readling threads, didn’t find answers, getting a bit tense - deep breathes… help would be appreciated.

  1. Did it compile before your friend added the autonomous code?
  2. If this is the first time you’ve tried to compile, did you make sure to set the project up for C instead of assembler?

#1 is important, because if it worked and then stopped you need to go back to your backup (hey, I’ve been programming for 22+ years and I NEVER backup anything up) and try again.

#2 is a problem we had the first time we tried to compile anything. The IDE thought we were programming in assembler and wouldn’t work until I changed to project to C.

Good Luck!

jdhawg, thanks for your input. I am working with Chuck and the programming on team 1696.

When you mention “C”, is it in reference to a setting in MPIDE? I have the code on my laptop and can try it now. Or, do I need a different compiler?

Thanks again for the help, this is the last step in the software prep.

Sincerely
George Murphy
Team 1696

thanks for the quick reply -

btw - the compiler seems to work for several minutes before getting the error message

re 1 - the prior code was default, although not compiled on this machine, so I think we have never successfully compiled anything on this machine.

re 2 - don’t know, will check when I go in today.