Compiling throws connection error for working roborio

For the past couple of hours, our team has continually attempted to update the code on our controller with no avail. Every attempt ends at Java.io.IOException: Connection is not open.
However, the driver station connects perfectly fine to the roborio, and we can drive with the code we previously uploaded. Uploading code worked just last week as, so we have no idea what happened in the interim that caused this issue.

So far we have tried:

Reconfiguring the radio
Reflashing the Rio
Connecting to the Rio with both wireless comms and with ethernet
Connecting using differenct computer.

We’re stuck, not even our mentor knows what is wrong with the robot. Any help in resolving this issue is greatly appreciated.
If it helps any, we are using Netbeans and the NI 2014 Java Plugins.

Can you give a pastebin link with your code and the error?

Are you sure? I don’t know of any NI Java Plugins and the official plugins for the roboRIO are the 2015 Eclipse plugins.

We were able to compile and upload code with the plugins on NetBeans before, so I’m not sure why its causing a fit now. We suspect its the environment causing the issue, but we are not sure why. I will upload the code we tried to deploy when possible.

You have to use Eclipse this year. The RoboRIO only work with those plugins.