Compressor Won't Turn on In Weirdest Way

Hello Chief Delphi members!

Today at our warmup day for one of the MAR FRC competitions, we ran into a major issue; our compressor won’t turn on.

While this may seem like something simple at first, we are having massive troubles being able to get it back on. When we left our shop, our robot worked flawlessly, compressor and all. When we get to the competition, suddenly whenever we enable the robot, the compressor won’t turn on. Literally nothing has changed on the robot.

We narrowed it down to the fact that the spike relay wasn’t receiving any signal to turn on, but from there we are stuck. The code worked previously and hasn’t been modified, we swapped out the ribbon cable, spike relay, cRIO cartridge, and digital sidecar, but nothing can seem to get it to turn on, with the exception of the extremely brief moment when you plug the ribbon cable into the digital sidecar while enabled. Does anyone have any advice or input? We all would really appreciate it.

Do you know what the relay light was doing on your sidecar today?

Try running a practice match. The big difference between competition and your shop is probably that you don’t run auto before you test in your shop.

Try switching the PWM cable.

Have you tried independently powering the compressor to make sure it hasn’t gone kaput, not that that happens often.

We have tried both of those with no luck. I will try running on a practice match as well. Any other ideas? We spent 6 hours with 3 professional electrical engineers (from other teams) with no luck.

If I remember correctly, the relay light was flashing on and off. I can triple check when we get there and better let you know.

Which compressor are you using? If you are using the small compressor (the one without casing), check the resistance between the leads and the casing (power to casing and ground to casing) against one fresh out of the box. I don’t remember the specific value, but if it’s significantly lower than your compressor has gone bad. We had the same problem yesterday.

Are you using a 20 amp auto reset breaker instead of a fuse?

Start with the relay light on the digital side car where your PWM is connected. Is it showing either side on?

If it is, then you have a problem downstream of the digital side car. Because the compressor blips when you plug it in, that would suggest that it’s not the breaker or the spike itself. Which leads you to the PWM. To further isolate the issue, is the light on the spike changing? What is its status?

Since we’re 8 posts in and everyone has missed this obvious bit:

Have you tested your pressure switch and the cable coming from your pressure switch? The compressor won’t run without a closed contact on the digital input for the pressure switch. So do this:

  1. Make certain the cable for the pressure switch is plugged into the correct digital IO AND the correct way.
  2. Short out the terminals on your pressure switch with a screwdriver or something. If the compressor runs, your switch is bad.
  3. If 2 doesn’t work, find a known good PWM cable, plug it into the pressure switch digital IO, and short the white and black pins together. If the compressor runs, either your pressure switch cable is bad, or the connection from the cable to the pressure switch terminals.

Wait… are you saying that even when you applied power directly to the compressor, nothing happened? That’s what that reply led me to believe at least.

In addition to what Kevin Sevick said, the relay light SHOULD be either a SOLID orange (meaning it is off) or a SOLID green, meaning it is applying power.

If it is blinking, it isn’t receiving a proper signal. Edit: Ignore that.

Ensure that you have the PWM cable plugged in correctly in both the Spike AND the Sidecar.

You may want to replace the Spike, if the relay light on the sidecar is on.

Spikes don’t blink, you’re thinking of victors and jaguars.

Yup, I sure am. :o