Connecting Camera to RoboRealm via D-Link

Hey all. Silver here.

Our team has encountered a situation where we are attempting to establish a camera for the first time. We want our Axis camera to be wired to our D-Link, which is wireless from the computer, then for the camera to appear in RoboRealm. We have successfully gotten the camera to show up in SmartDashboard, but cannot get it to show up in RoboRealm. Any help, links or tutorials would be greatly appreciated.

Thanks again.

To get a connection in RoboRealm, you have to use the Read_HTTP module, which is under Loading/Saving. Add that, then edit its settings. Type in the URL of your camera’s .mjpg file (the Camera Type box should get everything right but the camera’s actual IP.) Then click Start. That should do it!

If it still doesn’t work, try closing SmartDashboard - I’ve found that only one program can access the camera stream at once.

Much appreciated. Our programmer tried this out and (after a bit of struggling) figured it out and we’re all set up. Thanks!

Awesome, glad it worked. Also, it turns out I lied about only one program accessing the camera at a time - SmartDashboard and RoboRealm can access the feed simultaneously, no problem.

The MJPG stream is: http://[camIP]/mjpg/video.mjpg
You may want to disable viewing authentication. It caused some problems with OpenCV for me, so it may cause problems in RoboRealm

All you need to do to use the axis camera stream is to use the “Axis Camera” module in Roborealm. It works perfectly for my team.