Connecting Radio to RoboRio

We are trying to connect our OM5P-AN radio that came in the Kit of Parts to the roboRio.

When we turn on the power with both the roboRio and the new radio connected, the new radio takes awhile to initialize and the Ethernet link and status lights do not light up.
However, if the roboRio is disconnected from power and reconnected without turning off the radio, the radio connects fine. This leads me to believe that the new radio is taking too long to initialize.

We also tested the same situation with the old dlink. The roboRio connected fine without any problems.

So, currently we are using the Dlink for the robot. However, this will not be viable for competition season. Anyone else have this problem/know how to fix it?

We have also tried additional steps, which have been recommended for other issues with the new OM5P-AN radio.

  1. We reinstalled the FRC firmware for the radio. (This should not have been necessary)
  2. We reimaged the radio with our team number and country.

Does anyone have any solutions to the problem where the radio will not physically connect to the roboRio since the new radio takes so long to initialize?

Is your roboRIO running the new firmware and 2016 image?

Yes, we have updated the roboRio image to the 2016v19 version and the firmware to the 3.0.0f0 version.

Please do not tell me that after we go through the painful process of finding the correct radio configuration & firmware flashing instructions (fight all those too tiny wire connection holes on the crossroads electronics modules…OK, the CAN wires fit the holes perfectly I must admit…But, not many other wire sizes do!). And we finally achieve RoboRIO Firmware & Image Updating, and the Radio Firmware Updating and Configuration…That there are still more issues to resolve with the new & IMPROVED, but, not fully tested yet robot radio.

We are only 1.5 weeks into build season, and I am already totally exhausted! I want to go back to mentor the fabrication section already.

Crossroads Electronics…Please make those holes much bigger in the future? I’m begging you…Headed to my knees now. And as I order another Radio right now so we don’t mess up our HOME USE SETUP EVER.

As shown in this thread, another team has had issues with communicating with the roboRio. We tried hitting the reset button on the roboRio and it fixed the issue. However, we will need to do this each time.

This still appears to be a hardware issue with the radio. The only solutions that other people have been posting are to check a bunch of diagnostics. However, maybe more of these issues are due to a radio hardware issue.

We are still waiting for a better solution, because this issue has not occurred before this year.

As well, I have sent an email to AndyMark about this issue.

Sent an e-mail to FRC to suggest they update the RoboRio firmware to wait longer for the Radio to boot up.

With robots being turned on after they are placed on the field, this is going to be a problem. Since it is not a requirement to make the RoboRio reset switch accessible, FTA’s may or may not be able to quickly reset the RoboRio. Note: Powercycling the entire robot won’t help since that just restarts the timing problem.

I also have a support ticket in the works with AndyMark. They asked for some diagnostics and I sent them a few minutes ago.

Has anyone figured this out yet? We are also having this problem where we have to reset the RoboRio to get communications working.

Are you using the port closest to the power connector on the radio and have you tried switching ports?

We are having the exact same problem, and Resetting the Rio fixed it, however we have to reset it each time…

We are using the port farthest from the power connector as described in the “Programming your radio for home use” documentation. We did try the other port, but that only changed the problem. We were able to connect at power up, but then we couldn’t connect to the robot with ftp. We switched back to the original port to continue working on other tasks.

We have “figured” out the issue.

To fix it, use the port labelled 18v-24v POE. This connects quickly. However, this is different than the instructions on the WPILib.