Connection Issues

Hello,
Today we were trying to connect to our robot. We used last year’s robot (last year’s roboRIO, etc.). Prior to doing this, we re-imaged the roboRIO (we confirmed the new image was 2017v8), updated firmware on two radios (one from last year, one new one), and configured the radios to a 2.4 GHz access point. However, when we tried to connect to the robot, the wifi choices listed our robot, and allowed us to connect. However, the Driver Station did not see comms from the robot, and when we tried to visit roborio-4557-FRC.local through a browser, it said that the configuration page was unavailable*.

We also noticed that the wifi light on the radio (both were tried) turned yellow instead of the usual green. If you’re able to help us out, that would be great!

*I read somewhere that they took the configuration page away. Can someone confirm this one way or the other?

A yellow light on the radio is good when you’re connected.

If by configuration page you mean the radio’s web server where we used to be able to check and adjust it’s settings-that’s gone. The FRC radio firmware doesn’t include a web server.

I’d hook up a USB cable between your PC and roboRIO (while keeping the roboRIO connected to the radio) to see what Ethernet IP it got assigned and if it’s compatible with the IP your PC got assigned.

I’ll try it out tonight and let you know.

Also, a follow-up question:

If the config page is gone, how do we set device numbers for Talon SRX’s on the CAN network?

The roboRIO configuration page is still there.
Hookup your USB cable and browse to 172.22.11.2

Thanks for the help. We were able to connect today. One last question (hopefully :))*, we were able to connect to the new radio by ethernet today (as well as by wireless to the old radio), but we weren’t able to connect wirelessly to the new radio.

Couldn’t decide so here’s an xkcd comic on the matter https://xkcd.com/541/

Did the new radio show up at all in the wireless list on the PC?
It’s possible it uses the team number followed by an underscore (*4557_ *) for instance-depends on if you put anything in the Robot Name field.

What did the new radio wifi status light show?

I assume only one radio was powered at the same time and both were set for 2.4GHz operation.

  1. No, it did not show up in the list.
  2. The wifi status light was not on.

The radio was set for 2.4 GHz and operated alone. On set-up, nothing was entered into the robot name field.

If the wifi light was not on, then run the radio through the FRC Radio Config Utility again.
You can also try cycling the radio power.
For whatever reason, it failed to startup wifi.
If it starts correctly the wifi light should be red, before the PC connects, and yellow after it connects.

I’ll try it tomorrow and let you know how it goes. Thanks!

Hello,
Today we were trying to connect to our radio.
We used last year’s robot (last year’s roboRIO, etc.).
Prior to doing this, we re-imaged the roboRIO, updated firmware on the radio, and configured the radios to a 2.4 GHz access point. However, when we tried to connect to the robot, the wifi choices did not list our robot.
We restarted our computer and the robot multiple times but nothing helped.
Any advice? All tips or ideas are welcome!

Thanks in advance :slight_smile:

We are having a similar issue. We can connect wirelessly using the DS and the webdashboard to the RoboRIO, but cannot load programs using Eclipse with Java. This worked fine until we updated to the 2017 FRC Update, 2017 Radio Firmware, 2017 Eclipse FRC Plugins, and the 2017 RoboRIO image. The only way we have been able to program the RoboRIO since then is via USB.

The error that comes up prior to BUILD FAILED is a “connection refused” when attempting the connection to port 22 (ssh) on the RoboRIO. We tried turning off the firewall on the laptop, tried other laptops, tried a different RoboRIO, a different radio, re-imaged the RoboRIO again, re-flashed the radio again. We initially loaded firmware on the radios with the “firewall” box checked, so we ran through the process again without it checked (which is the default). That also didn’t make any difference. We also couldn’t ssh into the roborio from a Linux machine on the robot network, so it doesn’t appear to be an issue on the laptop side of things.

Has anyone else experienced these sorts of problems? Again, the robot can be operated wirelessly, and the webdashboard is working fine when connected wirelessly.

Thanks in advance for any suggestions.

A couple of things to try on the ssh and other connections that aren’t working-

(1) On one of the connections that won’t work, try connecting to:
roboRIO-2220-frc.frc-robot.local

(2) use IE or Firefox to connect to the roboRIO over USB and see what Ethernet IP the roboRIO was assigned (on the front webpage). Try connecting directly to that IP address.

(3) You can try hardcoding the roboRIO IP address to 10.22.20.2, however you must always have the roboRIO and PC connected through the radio for it to work.

Hello,
Our new KOP 12V OpenMesh radio still isn’t starting wifi, the wifi light doesn’t come on and the network doesn’t show up in the list. We realized we needed this fixed before competition, so it has become urgent. We tried reconfiguring- still no wifi. We reloaded firmware and reconfigured- still no wifi. At this point we do not know our other options. Any help is much appreciated.

If the radio wifi light doesn’t come on it can’t work.

Is the radio powered by one of the VRM 12v/2a connections? The 12v/500ma connection doesn’t supply enough power for the wifi to reliably operate.

Are you reinstalling the firmware & reconfiguring the radio from different PC’s, in case it’s a PC hiccup?
Do you have last year’s radio to try?

Is the roboRIO Ethernet cable plugged into the radio port closest to the power connector?

It is connected to the proper power connections. Last year’s radio still works I believe. We have not tried installing it from different PCs. Is last year’s radio legal to use this year?

Yes, last year’s radio is legal.

Thanks :slight_smile:

Mark, thanks for the tips. However, we do not have issues connectly wirelessly when using either the Driver Station or the WebDashboard – both work fine. It is only when trying to download a new RoboRIO program from the Eclipse environment which uses SSH on port 22 under the hood.

We are going to try different firmware tonight to see if it makes any different (2016, and 2017 kickoff – we are currently using the latest firmware from 1/8/2017 I think).

We have narrowed down this problem to the FRC Radio Configuration Utility (both version 17.0 and 17.2). Whether we check the “Firewall” box or not, TCP port 22 is not allowed through the radio to the RoboRIO. We have discovered how to get around this by logging into the admin interface on the radio (port 22!) and using appropriate configuration commands to add port 22 to the list of ports allowed through.

While this appears to be a bug in the FRC Radio Configuration Utility, I have not gotten confirmation of this as of yet.