Connection Problem?

Turning testing we encountered a problem where the communications kept getting dropped between the robot and our driver station computer. The radio is in 2.4 mode connected directly to the laptop via wifi (i.e. not using a router).
After the robot disconnected it would reconnect after 30-60 seconds. We never lost the wifi “network” on the computer as far as I could tell.

We originally thought that the radio might have been browning out however we confirmed that the radio never loses power. We watched the lights on the radio as well as observed the network on the laptop. The issue seems to be between the rio and the radio. We tried swapping the cables.

It started doing it when we were driving over the scoring platform (with a lot of bumping around) so we thought that maybe something was coming loose. However after 4-8 lost connections it didn’t seem to matter how much the robot was bumping around.

Normally I would assume that it’s some software, firmware, or hardware issue on our end. However I have spoken to one other team who reported the same issue with no solution as of yet.

Is this behavior anyone else has noticed? Are there any proposed solutions? Might this require an email to FIRST?

Is your battery low and/or roboRIO browning out?

There aren’t any 2.4ghz wireless phones nearby, are there?

Do you have the same problem in 5Ghz mode?

What events does the Driver Station log show happening when the communication goes bad? It can usually distinguish between problems with the network and problems with the roboRIO.

Team 1619 had a similar problem with our test chassis that we were able to solve, but it may have been a different cause than yours. Our robot kept losing communications, especially going over the bump, but we believed it to be a loss of power to the router since the D-Link light would turn red after we lost communications (as though it was rebooting). The computer never appeared to lose connection either, which was part of why we originally thought it was a computer or router problem.

We swapped routers and had the same issue, but found that swapping our Voltage Regulator Module solved the problem (at least until someone pulled a “Dukes of Hazzard” jump over the scoring platform and jostled the power connector free). Our best guess is that the one we had been using for testing was faulty, since it worked flawlessly after replacing it.

Please click on the Logs… button on the top of the driver station. It will bring up another utility that will show the voltage, CPU, and errors that were logged when your robot was connected to that DS.

Click through some of the logs where you saw this and see if you can determine what happened. If not, please post a screenshot or post the log files, both the .dsevents and .dslog.

Greg Mckaskle

Try using a cable between your LAPTOP and the DLINK. If this doesn’t solve the issue, perhaps try a different DLINK?

Thanks for the input - this is the team I am working with as well.
The problem does not appear to be in the DLink…both lights remain blue when we lost communication.
We can run the robot, but when we hit the ramp, or jostle heavily it loses com.
We have replaced the ethernet cable, taped it into place, etc…driver station is showing an occasional brownout, but it doesn’t seem to correspond with our times the robot loses com.

I will post the screenshots after tonight…unless someone has any other ideas. It really seems to be an issue inside the RoboRio.

The lights don’t necessarily indicate that you have a wireless connection. One indicates that the DLink has power, the other just indicates what the router is serving a wireless AP.

Just to clarify, have you tried running teatherd between the LAPTOP and the DLINK?

Thanks - we can’t run the robot around with it tethered. We only lose com when we are running around and jostling the robot.
Right this moment we are running fine with a piece of foam under the RoboRIO…we’ll see if this continues.

If you suspect that jarring the roboRIO is causing a problem, look closely at its power input wiring. Make absolutely certain that the screw terminals are tightly holding the conductors, and that there is no bare wire showing. Especially check that there are no “whiskers” of stranded wire that might have escaped the connector.

Just a side note.

I’d recommend you purchase a long (seriously, there’s no such thing as too long) ethernet cable for use on the practice field, because you will be using the practice field.

OK- so we put a piece of foam under the RoboRio and had no issues practicing all last week. Tonight we hit the wrong side of our practice scoring platform, and lost communication briefly. Now it is happening with jostling again.

We are able to communicate again fine after about 25 seconds without touching the robot. We have checked and re-checked all of our connections, and are not seeing any issues. We literally ran with no issues all last week, practicing every night!

Any other ideas