Control System Problem Help?

Good afternoon,
We are a rookie team and having a couple of problems. We first uploaded the update to our driver station prior to performing initial control system testing (mistake 1). Then we couldn’t get the driver station to talk with the CRIO. We thought perhaps there was a way to revert the driver station to Out of Box revision. We couldn’t find a way to do that (mistake 2) so we took someones advice to someone else on the forum and reformatted the CRIO (mistake 3) and then updated it with latest firmware. Then we could get the CRIO to provide battery data to the driver station but we still have flashing yellow lights on our jaguar controllers. We have triple checked the wiring, replaced one of the controllers to see if the “new” one worked (it didn’t so we switched back), installed the 6v jumper on the digital sidecar and checked for proper voltage output (we got it). We thought maybe the CRIO’s default program was wiped so we tried to install a new program (now the driver station doesn’t see the battery anymore get a “No Code” fault code). The digital sidecar is getting the correct input for robot online or offline (indicated by the light) but we get no signal to the jaguars.
Could it be that we wiped the default CRIO program and now it doesn’t know to tell the jaguars to turn on?
Could there be a problem with the digital module on the CRIO?
Any ideas would be greatly appreciated.

Thanks!:confused:

We had a similar problem that started with the download of the cRIO firmware. It sounds like the IP address of your cRIO was reset to 10.0.0.2.

Get the Control Systems Configuration Guide (Chapter 5 of the Control Systems Manual) from the FIRST site. The cRIO firmware download instructions start on page 4. Make sure you set your team address before you do the download.

Hook up all the components as shown on page 6. On your laptop open a cmd window (start, run cmd). Use the foillowing commands:

ipconfig (shows your laptop address)
ping 10.xx.yy.02 (xx and yy are your team number. This shows the cRIO is the correct IP)
ping 10.xx.yy.01 (Shows you can see the bridge from your laptop)

Hopefully, this will get you started back up.:slight_smile:

We used the pinger utility to verify that our IP address is right. Does anyone know about the reset button on the cRIO? Would that take us back to default programming?

Thanks for the help!!!

You can’t go back to the original cRIO OTB program, but you don’t really need to. You can complete your bench test using the default program that was loaded onto the cRIO when you installed the firmware update.

The behavior described by the manual will differ, but a successful bench test just makes sure that when a joystick moves at one end, a corresponding motor moves at the other end.

The cRIO reset button is just another way to reboot the cRIO, like turning it on and off, only without the power going away.

So your team number is now set on both the DS and the cRIO?
But your problem is primarily that the jaguars are blinking?

They pushed down to the cRIO the default Labview program and it now is working but both motors are being controlled by the right joystick. We are now working on our C++ programming so that we can run it on Windriver. Thanks for all your help and ideas.

The default program that the FRC cRIO Imaging Tool sends to the cRIO is actually a Wind River program and with Wind River Update V1.2 you can find that program under the Examples along with the original OTB program.

The default program uses the throttle on the USB1 joystick to select between 1-joystick arcade drive and 2-joystick tank drive.

For some reason when we try to program our team number into the Control Station, it’s not reasponding. We are folling the instructions in the manual perfectly, but it still doesn’t work. I’m confused if it is user error, or something different. Anything helps.

Have you updated the driver station? The DS update must be installed for the team number to be set.