Converting Eclipse Code to Visual Studio

Hi there,
So I am trying to convert some code from an eclipse project into a visual studio project and something appears to have gone wrong. I used the WPILIB import function but this is the error I am getting and I am not sure how to fix it exactly. Any help would be much appreciated! My team does not have any programming mentors and I am not the greatest so please forgive me if I am asking a stupid question.


Update: This is happening for all new projects not only imports. It is making me think something is configured wrong.

It looks like your code built successfully, but the intellisense hasn’t caught up. What happens if you close vscode and reopen?

the same error pops up. Even tried restarting the whole computer and same thing still appears

Try pressing Ctrl+Shift+p and running the Java: Clean the Java language server workspace then reopen VS Code.

Same problem still occurs

The problem has gone away at this point. I had to completely uninstall visual studio and reinstall it. Doing this seems to have fixed the problem for now

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.