"could not find rev color sensor"

If you need any more information, let me know
so im code monkey this year and our rio wont find the new rev color sensor when we’re deploying code
we attached the cord onto the i2c port correctly
here is the error directly from the console:

Could not find REV color sensor
Error at com.revrobotics.ColorSensorV3.checkDeviceID(ColorSensorV3.java:380): Could not find 
REV color

we tried running rev’s example code as well as our own code and it still wasn’t able to find the sensor (and we kept getting the same error) so we’re convinced it isn’t a code issue.

did the LED work when plugged in?

Along with @klhutchi’s question, I’d like to confirm it’s wired correctly before progressing with code. Can you share a picture of the wiring on both sides (sensor and Rio)?

I worked with OP on this. The LED did work. As to the wiring, I don’t have a picture but Im pretty sure we got power and ground wired properly.

We tried swapping sda and scl and got the same error for both

Did you install the Color sensor libraries?

Yeah, we have all the dependencies, etc.
Basically when we deploy code to the rio, it builds and deploys successfully, but then gives us the error saying it can’t find the colour sensor.

We are experiencing the same issues. LED is on on the color sensor, but always “Could not find REV Color Sensor”. We tried a different cable, as well as three different laptops and two different RoboRIOs. Of note, we also tried both the onboard and MXP I2C ports, with the same result. I am starting to think that our KOP sensor is DOA. If anyone finds a gotchya that would be great to know about

Our team ran into the same problem. Like @AndyB871 mentioned, we tried different cables, driver stations, roboRIOs, and both I2C ports with no success. We even took it one step further and tried directly calling I2C library code (i.e. HAL_TransactionI2C()), as well as tweaking the rev library code to try and just get simple responses out of the sensor, but nothing worked. In the end we ordered new sensors, and one of the new ones worked no problem. I suspect there are problems with some of the shipped sensors and recommend ordering a new one.

@AndyB871 Please reach out to support@revrobotics.com so that we can get you up and running. If you have already, PM me the email address you used so that I can make sure we received your support request.

@amperes_cool_ohms Did you reach out to us before purchasing a new sensor? If not, please still send us an email so that we can understand what is happening. It is highly unlikely to have a large quantity of failures in a row, so I want to try and figure out if there is a setup or wiring problem so that you don’t see any more.

@dyanoshak We experimentally took off the plastic cover of the sensor and discovered that the SCL and SDA pins were shorted together from the factor. Looks like a bad solder mask. We repaired it by hand, sensor seems to be working now

@dyanoshak, after @AndyB871 posted his image, we took ours apart as well. We have the same problem where SDA and SCL are shorted together. Additionally, our ground pin has virtually no solder on it.

Thanks for the photos @AndyB871 and @amperes_cool_ohms. We will be investigating how these slipped through the factory test.

Thanks for this photo!
Can confirm, had the exact same issue and was running around in circles trying to figure it out.

I’ve been having the same issue. I took the sensor out of the housing, and checked for soldering issues, and there were none. Any ideas?

Please send us an email at support@revrobotics.com and we’ll get you up and running.

Having this same problem, the sensors did work on our test board but im getting this error while moving them to the robot. I am using new extension cables but I tested continuity and everything seemed wired correctly. I have 2 sensors one in the onboard I2C and one in the MXP I2C. The on board one is throwing the error, however the MXP one never throws an error regardless of whether its plugged in or not so we arent sure if it works or just isn’t throwing an error. Anyone have ideas?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.