Was just reading some code on some team’s github pages and saw this:
// Java multithreading magic. Do not touch.
// Touching will incour the wrath of Cthulhu, god of java and LED Strips.
// May the oceans of 1's and 0's rise to praise him.
private class DotStarsTask extends TimerTask {
private DotStarsLEDStrip m_leds;
public DotStarsTask(DotStarsLEDStrip leds) {
if (leds == null) {
throw new NullPointerException("Given DotStars Controller Class was null");
}
m_leds = leds;
}
@Override
public void run() {
m_leds.updateColors();
}
}
One of the programming students left little notes all over the code (we use labview) one day for me to look at to try and help him fix it, but one of the comments read “DO NOT TOUCH! I promise this works (sorta)” and another which dubbed the robot, computer, and code all potatoes.
/* Heisenberg Code: do not add debug statements */
# HEH HEH HEH, EH!
There’s an error message in some code at work which converts the legacy format data into an even older format with an error message that mostly occurs after a system upgrade:
Armageddon has occurred.
Please proceed through the portal to the afterlife of your choice.
The guy who wrote that moved on to another project several years ago, but the error message hasn’t changed, because the new programmers now know what an armageddon error is.
Edit: One of our programmers called our 2014 ball intake process “tickle” in code.
It was code that, while we all understood it, was one of those things only someone with a love of functional program could like. Which on that team was mainly me.
//This is important Java voodoo magic. It loads the JNI component of OpenCV using alchemy and magic.
//System.loadLibrary(Core.NATIVE_LIBRARY_NAME);
System.loadLibrary("opencv_java310");
In our robot code, our vision LED ring is called variously “greenRingOfDeath”, “greenSauron”, and “eyeOfSauron”. They weren’t joking when they called it SuperBrightLEDs.
I was helping a team debug their code, and every one of their Class names was a different four letter word. Completely unrelated to it’s function. For example:
Sh*t sh*t1 = new Sh*t();
(except without the *)
I tried to get them to rename stuff to better describe what it does, but they were very happy with the names as they were.
I’ve never checked for it, but I heard that our 2015 manipulator, BiLL (for Binary Load Lifter) had some comments indicating C3PO was one of the programmers. :]
I was reading through 254’s code from 2015, once upon a time, and I remember something that made me laugh. They had a comment for what I think was a tote intake roller, and the comment was something along the lines of
// SpinnyThing™
The TM part I thought was very subtle and funny
It’s still there, if you can find it.