Create a New Subsystem Not Working in FRC 2020

Hi,

Just installed Labview FRC 2020 and tried to create a new subsystem which did not work. When I opened my project, I right click on RoboRIO target and click on New >> Subsystem but there is no popup. Instead there is a new item called VI-Based Object. I tried this with a brand new clean project and also last years updated project - same result. See below for new item created.

image

Has anyone else tried creating a new subsystem and had this same problem or success with it?

Thanks

Experiencing the same issue. The work around that I did was to open up a new project in 2019 LabVIEW and create the subsystems. Then copy the folders into your 2020 project. Right click on the roboRio in 2020 LabVIEW project and add folder (auto-populating). Make sure after you do that you put the subsystemName controler.vi into the Subsystem.vi

Thanks for the solution. Unfortunately I followed “Best Practices” and uninstalled 2019. I guess I’ll wait for NI to provide a solution. Do you know if I can I install 2019 with already installed?

Should be fine to install it. I’ve never had any issues having two versions installed. Hopefully NI will have a fix for this soon, but if not you can do the above workaround if you need to start working right away.

This is an unofficial fix.

It looks like the VI at C:\Program Files (x86)\National Instruments\LabVIEW 2019\resource\Framework\Providers\FRCSubsystem\PrimaryProvider_CreateDummyObject.vi is what creates new Subsystems. It has a broken run arrow.

The fix is to make a backup copy of the C:\Program Files (x86)\National Instruments\LabVIEW 2019\resource\Framework\Providers\FRCSubsystem\Rename Templates.vi VI, then open it and simply delete the broken wire.

Close the VI and everything should work.

I believe this is relatively safe because the “Subsystem Name” terminal that the broken wire is connected to is not connected to anything inside the “Fix Read Op Value” VI. I don’t completely understand the surrounding code yet but I think it has to do with the VI icons getting changed with the subsystem name.

Look for an official update from F.I.R.S.T. and National Instruments in an upcoming update.

2 Likes

Thank you - that was some good debugging! I was hoping there was a workaround for this - but I couldn’t find it. Will try it tonight on my system.

Thanks for getting back to my question. Just to let everyone know, I did install Labview FRC 2019 with 2020 already installed and 2020 did break (could not deploy - might be fixable but I did not try). I guess if you install newer version over older it should be ok, but not the other way around. Plus my 2019 license was expired so that was another issue fro me.

Thanks again for the help.

@Greg_McKaskle @oscarfonloz do you know anything about this issue?

Nothing more than what is in this thread.

Have you tried talking with him, or with anybody else from NI?

I am monitoring the thread and NI is aware of the problem. Unfortunately, I have no further information yet.

@bohdand, you can find the fix in your NI Forums’ post: Re: Create a New Subsystem Not Working in FRC 2020

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.