create new robot project fails.


I’m an experienced labview programmer but I cant get the latest install to correctly create a new robot project. It abortes just after it loads the robot

Ive done all the updates and I CAN build the dashboard but not the robot project.

I am running on a brand new ASUS i7 windows 8 laptop that I got for this season.

Ive posted full details at the NI link below

Any suggestions?


Reboot your computer.

If I understand correctly, I had the same problem.

Ditto. Same problem here and a reboot fixed it.

I haven’t run into this on my computer, but saw it last weekend at a training. The PC was close to 2GB of RAM in use, and one of the FPGA VIs would return a memory error during compile& download. Reboot fixed it. Please let us know if this happens very often. I can’t really see a leak or explain why the FPGA VIs would be succeptible to this, but, …

Greg McKaskle

Sorry, I tried reboot rigth away. No effect.

Note: This occurs during the “New Robot Project” process, not a download.

Laptop has 8GB or memory.

I have been given some suggestions, I will let you know results.


I had the same problem, I rebooted to fix.

So far I’ve tried several sugegstions but still with no avail.

Since the issues seem to be with some of the Rock Robotics routines, I have tried a Mass Compile of the folder.

This process produced a large number of errors which are listed here:

Scroll to fourth post.

I generated a MAX Log and uploaded it to provide additional information.
Next, in the event that there had been a bad install, I deleted the entire Rock Robotics folder and did a Repair install of the NI_LabVIEW Update.

Still the same problem.

I went and looked at one of the VIs listed as bad in the mass compile: C:\Program Files (x86)\National Instruments\LabVIEW 2012\vi.lib\Rock Robotics\SystemInterfaces\AnalogTrigger\

It did in fact have several broken wires. (see snipit at end of thread on NI forum listed above)

It’s feels like some VIs that interact with certain portions of the FPGA have broken interfaces. Could there be a problem with the FPGA library, or perhaps my RT environment is not working? Just clutching straws.

I’m dreading a full LabVIEW un-install/re-install because it takes so darn long. (even with a top of the line machine).