cRIO connection issue-can't deploy code

We are using labview to program our robot and our code looks like it works and no issues are detected when we build the code, but when we try to deploy the code the dialogue box comes up and says:

>>Initializing…
>>Calculating Dependencies…
>>Checking items for conflicts. This operation could take a while…
>>Waiting for Real-Time target (RT CompactRIO Target) to respond

At this point a new box comes up with this error:
>>Failed to connect to real time target
and gives me only one option to cancel.
When I do it says:

>>Current Operation Cancelled

I don’t know what the problem is though. We’ve tried doing something with the network, but when we ping the ip of the cRIO it says that it’s connected. We also don’t believe it is a hardware issue so any help would be appreciated.

Have you verified that you have the correct IP address set in the Project Explorer window in labview? It should that 10.17.18.2 (insert your team number in place of 17.18). If it sawys 10.XX.XX.2, you haven’t configured it for your project.

Yes we have checked that and it says 10.13.7.2

Is the firewall on your computer disabled? If not, try turning it off. We had problems last year with connecting to the cRIO, but we use C++ so yours might be a labview-specific issue.

We just tried your solution, Jasmine, and we got the same result as before.

When you reimaged your cRIO this year, did you choose the LabVIEW option?

Have you verified the IP address on your computer is 10.13.7.5? What is your subnet mask set to?

Connected wired first, make sure your wireless and IPv6 are turned off.

Things to try, some of them already mentioned:

  • Disable all other Network connections leaving only the one you are using for the cRIO.
  • Turn off all firewalls and anti-virus programs
  • Verify the remaining connection has an FRC valid IP address, i.e., 10.13.7.5 (for Ethernet) or 10.13.7.9 (for wireless), Check the Advanced button for multiple IP addresses and delete any extras.
  • Start the Driver Station to see the Diagnostic tab ping verifications
  • Try connecting your laptop directly to the cRIO vis Ethernet cable
  • Type ipconfig /all
    in a command window to verify what your network connections are.*]Close the Dashboard if it is open and reboot the cRIO. There is currently an issue if the Dashboard is trading data with an existing program on the cRIO.

I have just changed the IP from 10.13.7.10 to 10.13.7.5 and out subnet mask is set to 255.0.0.0 and the default gateway is set to 10.13.7.4. I have also just turned off the IPv6. We are still getting the same issue but now we no longer have communications or robot code in the frc driver station.

Also we are connected directly to the cRIO via Ethernet cable if that makes a difference.

I just want to ensure that your wireless adapter is disabled or at least not connected to a network. Also set your subnet mask to 255.255.255.0 for programming.

The “Failed to connect to real time target” error suggests either a network problem or a misconfigured cRIO. If you can ping the 10.13.7.2 address, the network is probably okay, but you should double-check by using the ipconfig command. Can you copy and paste the results of ipconfig /all here so we can help you narrow down the problem?

The issue isn’t the volume of data being transferred. It’s a bug in the Network Tables server that keeps the cRIO program from being terminated when there’s a current client connection. Closing the Dashboard is the suggested workaround until a software update is released. Rebooting the cRIO is not necessary.

When I pinged ipconfig/all this is what came up

Windows IP Configuration

Host Name: (my name)
Primary Dns Suffix:(blank)
Node Type: Hybrid
IP Routing Enabled: No
WINS Proxy Enabled: No

Ethernet adapter Ethernet:

Connection-specific DNS Suffix: (blank)
Description: Realtek PCIe GBE Family Controller
Physical Address: 08-2E-5F-7B-6B-38
DHCP Enabled: No
Autoconfiguration Enabled: Yes
Link-local Ipv6 Address: fe80::dc16:faef:92f9:7b3d%12(Preferred)
IPv4 Address: 10.13.7.5 (Preferred)
Subnet Mask: 255.255.255.0
Default Gateway: 10.13.7.4
DHCPv6 IAID: 25219439
DHCPv6 Client DUID: 00-01-00-01-18-4a-43-38-08-2E-5F-7B-6B-38
Dns Server:
fec0:0:0:fff::1%1
fec0:0:0:fff::2%1
fec0:0:0:fff::3%1
NetBIOS over Tcpip: Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State: Media disconnected
Connection-specific DNS Suffix: (Blank)
Description: Teredo Tunneling Pseudo-Interface
Physical Address: 00-00-00-00-00-00-00-E0
DHCP Enabled: No
Autconfiguraton Enabled: Yes

Tunnel Adapter isatap.{A66FC120-4B59-4ABA-A50D-275EF46A6B6B}:

Media State: Media disconnected
Connection-specific DNS Suffix (blank)
Description: Microsoft ISATAP Adapter #4
Physical Address: 00-00-00-00-00-00-00-E0
DHCP Enabled: No
Autocnfiguration Enabled: Yes

You probably want to turn IPv6 service off.

I suspect you didn’t actually copy and paste that, because there are misspelled words and inconsistent lines, but I’ll trust that the content accurately reflects what you got.

With the possible exception of the IPv6 support, everything looks the way I’d expect it to for a properly-configured system. The next step in my troubleshooting script is to verify that the cRIO is correctly imaged. Run the 2013 cRIO Imaging Tool and tell us what it says (a screen capture would be helpful).

We turned off IPv6 and ran the cRIO imaging tool and an error message came up that said:

"No CompactRIO Devices were found

Verify an Ethernet connection between the CompactRIO device and the computer, and then turn Windows Firewall Off while imaging the CompactRIO device."

The windows firewall is off but I’m not sure if the computer is connected correctly to the cRIO.

Check the items I bolded. If you disabled IPv6 why is it still showing up in ipconfig /all?

You can try the troubleshooting information in this document.

Try setting your network config back to default and startover, following the instructions in the above document. You may have inadvertently changed something.

Troubleshooting cRIO Imaging

If the cRIO Imaging Tool is unable to locate the cRIO, or a Timout error message is displayed during cRIO Imaging, the issue is likely with the network configuration. One or more of the following steps may be necessary in order to image your cRIO:

Disable all other Network Adapters on the computer. Open the Network Connections window from the Control Panel (see Network Adapter Properties step above), then for each adapter other than the Local Area Connection you are using to image the cRIO, right-click on the adapter and select Disable.
Try using a network switch between the cRIO and computer: Some computers have issues reconnecting to the cRIO after the cRIO reboots as part of the imaging process. Placing a switch between the two devices, such as the D-Link DAP-1522 provided in the Kit of Parts typically mitigates this problem.
Disable Windows Firewall: Windows Firewall may be blocking the cRIO Imaging Tool, preventing it from detecting the cRIO. If possible, temporarily disable the Firewall by going to Start > Control Panel > System and Security > Windows Firewall > Turn Windows Firewall on or off. If the Firewall cannot be disabled, make sure that the FRC cRIO Imaging Tool is allowed through by selecting Allow a program or feature through Windows Firewall from the Windows Firewall screen, then click Change Settings and make sure that FRC CRIO Imaging Tool is listed and has a checkmark for all three network locations. If it is not listed you will have to add it using the Allow another program… button and browsing to the imaging tool location C:\Program Files\National Instruments\LabVIEW 2012\project\CRIO Tool
Try a different PC: If none of the above steps work, try using a different computer to image the cRIO.

We were able to successfully connect to and reimage the cRIO but now when we deploy the code we get a new error. It says:

“Access denied: This target is running a version of LabVIEW Real-Time that is different than the Real-Time Module software on the host computer. You can verify the version and reinstall the Real-Time software using Measurement & Automation Explorer.”

Any advice is appreciated.

First, reopen your imaging tool and verify that it says that the cRIO’s current image is 47.

Next, verify that you’ve installed the labview updates from usfirst.org (Including the bridge configurator, I believe there are 4 total).

Make sure you selected LabView when imaging, not Java or C++.

We had this issue on Team 3389 last weekend and it drove me nuts as the programming mentor.

We finally spent a few hours on the phone with NI on Monday and discovered there is a bug in the Smart Dashboard code currently. There are two workarounds, one of which I forget.

The work-around we are using is to shutdown the Dashboard app until AFTER you’ve deployed your code (via deploy or running from Robot Main.vi)

Since starting to use this work-around we’ve had no issues. I’m surprised this hasn’t made it to an update or official blog post.

Hope this helps,
James Culp
Programming Mentor
Team 3389 RoboSpectrum
http://www.team3389.info/