cRIO Connection Issues

Hey guys,

My team was trying to test our code but when our lead programmer tried to connect an error message came up saying "Connection failed. The network address might be invalid or the target is not responding. " We have read other threads on Chief Delphi and troubleshooting websites but no solution works. Any ideas what might be the problem? Thanks.

Team 4111 Peace, Love, Robots

It would be helpful to know what you’ve checked already, but I’ll start with the basics.
Make sure the computer’s IP address is compatible. It should be something like 10.41.11.5 or 10.41.11.6. You should be able to ping 10.41.11.2.
Also make sure you’re firewall is turned off.
Make sure your computer is connected to the robot - try it with a cable if you’re currently using wireless. (Make sure you set the appropriate interface’s IP address).
If that doesn’t help, let us know if you are able to ping it or not. And let us know if it has worked in the past from this computer, or another computer. Or try another computer.

What programming language?

Have you set your program’s options so that the computer knows what address the robot is at?