cRio does not work

Not sure if this is the right place, but we’re desperate.

We will be taking part in a competition tomorrow (11/13) and our cRio does not work on occasion. Every time we kick, the cRio essentially dies. Our bridge establishes wireless communication with our driver station, but it cannot establish ethernet connection the cRio. Does anyone have any suggestion on what we can do to fix the problem? Please help as soon as possible. Thanks in advance.

FRC 3167

Shot in the dark, but have you tried replacing the ethernet cable between the bridge and the cRIO? Simple enough to try.


Have you tried a fresh battery?

Have you checked all connections to make sure they’re tight?

The fact that this happens only after you kick seems to indicate that something is getting jostled loose, or that power is getting drained. I’d look particularly closely at the bridge-cRIO cable and ports, and the power connections on the cRIO, to make sure that they’re working and secure.

We’ve determined that the breakdown occurrs between the bridge and the cRio. The lights around the ethernet ports (a green and/or yellow) do not light up which leades me to believe that something has been knocked loose in the cRio.

Also, the indicatore light (the big orange one) does not turn on after this happens. Next time it occurrs, I’ll take some pictures so you all can see what I’m attempting to describe.

The robot signal light is controlled by the digital sidecar which is controlled by the cRio. Make sure the power wires for the 24 volts are secure both at the board and on the cRio.

I will reiterate to switch out the ethernet cable to make sure it is not wiggling out.

Also what is your battery voltage reading when this happens? Are any of your motors running when it happens?

Our next update is as follows:

We took off the cover of the cRio and tried gently tapping the board in various spots. Just by gently tapping the board, our connection is lost.

In response to one of the previous posters, we have tried a different ethernet cable and that has given us nothing.

Sounds like you may have a loose ethernet connection on the cRIO side. I don’t know if there is a fix for that; someone else might. There are ways to help prevent this, but they may not work against all possible cRIO impacts.

Hi Joe,

here is a quick troubleshooting list that you should do:

  1. Run through the Cleaning instructions for your cRIO and install the gaskets if you have not already. Here is a link to the directions on how to do so

  1. Double Check Power connections, Make sure to pay attention to the PD Board to see if any of its LED flicker.

  2. If that fails you might consider calling the NI Customer Service to start the RMA process at 866.275.6964

You might consider posting over at as we monitor that much more closely than CD.

Please keep us posted on how things turn out

Joe covers most of the bases but if you still are having trouble try a small screwdriver handle (the insulated part) tapped lightly against the side of the ethernet connector on the Crio board. An over anxious student may have lifted the connector off the board. In general these are not easily repairable and certainly not for someone who doesn’t do this on a daily basis.
Also be extra sure that the power connector is terminated properly. If you think it might be a problem, reterminate. I have seen more than ten teams who have had a small whisker of wire shorting out the power supply input to the Crio. Give it a tug test when you are done.

We will be there (Ramp Riot) too. We have a spare cRIO we can let you use for the competition.

What do the other LEDs on the cRIO do when you lose connection?