cRIO FRC Imaging Tool Error

Hello! Has anybody has problems with the imaging tool? Since I joined my actual team last year, we hadn’t been able to flash the cRIO with the tool, and instead had to access the ftp server on ftp://10.x.y.2 and place the image manually. A few days ago I tried changing the name to CDCH2576, and it magically worked! But this error repeated itself today, when I was skyping with team 4960 Polibot (San Carlos, Chile). I was trying to flash with the name “POLIBOT4960”, but the cRIO was once again unreachable. So when the other team programmer arrived, he reminded me of what I had done with the name, and not surprisingly, the name “POLI4960” worked! So any idea of what’s going on? We had a theory of the cRIO working with the old DOS 8-character naming system, but I highly doubt it :confused:

We may be seeing the same thing. Once the CRio became unreachable, how did you get it to communicate again? Thanks

What IP address was your laptop using when you tried to image it?

Where you going through a router, over WIFI, through the bridge, or directly to the Crio?

Can you ping the Crio when it fails to show up in the imaging tool?

It would help a little bit if you could give a little more detail about your setup.

The IP displayed by the cRIO was originally
I selected and as gateway.
They had a crossed ethernet cable directly from the cRIO to the PC.
And the cRIO never failed to show up in the imaging tool, it just threw an unreachable error after trying to connect.
Eventually the cRIO had as the IP, which was the original one I tried to assign it. We then managed to flash it with that name (“POLI4960”), but not with the longer one (“POLIBOT4960”)

use as your computer’s IP address and as the subnet, dont put a gateway unless you’re going through a router or the bridge.

any specific reason for using number 6? cause we always used 5.
and concerning the gateway, I thought it was best to use because I was going to change the IP…mind explaining why it isn’t necessary?

When First started using the 8 slot crios the manual and all the NI reps said to use 10.XX.YY.6 when imaging the crio, since then whenever I have had a problem with one, I use .6 and the problem vanishes 99.99% of the time.

As for the subnet, I have seen a few cases where setting the subnet to makes a difference. It really shouldn’t matter, but you can’t argue with the results in most cases.

Hope this helps!

Hahaha, you’re right about the results. Well thanks for everything!

No problem, glad I could help you out!