CRio II will not communicate

Good evening,

We have attempted to image 2 of our CRio II (4 slot) units with the 2014 image ( Initially, we could connect to the CRio II both directly and through the access point. When we used the imaging tool, it found the CRio, we put in our settings, formatting began, and the unit got to the “rebooting state” and got stuck there.

After waiting about 10 minutes with no change in the rebooting status, we shut off power to the Crio to start over.

Now, we can’t even ping the CRio. Our best guess is that the IP address somehow got changed, but we can’t find any documentation that gives us a decent guess at what address to ping. (or maybe this isn’t the problem).

Of course, we decided that something strange happened and repeated the process on another CRio. So, now we have 2 CRios that we can’t ping.

After 3 hours of effort, we bow to your support. Any suggestions would be appreciated. We think we tried all the troubleshooting documented thus far.

We did find that our computer IP was (not 10 or above). We have changed it to .10 now.

The AP is and the CRio was (when we could ping it).

Again, any help is appreciated.

Thanks, AJ & Parker

Make sure you have your TCP set to ‘use this IP’
and for you it should be ‘’

If all else fails, NI support will be able to help you out. I just hope you haven’t turned your cRIO’s into “bricks”

My team had a similar issue, in which we couldn’t update a cRIO, and one of our programmers shut off the power.

What worked for my team was simple: just reset the cRIO using the reset button. After resetting the cRIO, we were able to connect to it and image it like normal using the imaging tool.

Hope that helps!

When you are imaging the cRIO dont connect through the router, just connect straight into the cRIO Ethernet port. Not sure exactly why but the signal that the cRIO rebooted gets lost sometimes with the router. I just had this same issue over the past 2 days

Yes, we tried this too before losing communication with the CRio. It resulted in the same state of waiting for the CRio to reboot. The troubleshooting guides say to avoid this you should go through a router. So, that is what we did, had the same problem and then it was compounded by the additional inability to communicate with the CRio.

So, until we find a way to restore communication with the CRio, imaging it has been taken off the table :slight_smile:


We reset (holding the reset button to put it in safe mode) the CRio several times and unfortunately it did not restore our ability to communicate.

One thing we did not try is removing power from the CRio and then holding the reset button as we power up the CRio. Any chance that is what you did to restore communication?


Our “TCP”? The computer’s IP is set to The CRio was originally communicating on (meaning we could ping it and the imaging tool found it and tried to image it). Our present guess is that the IP address of the CRio was somehow changed.

We were unable to download wireshark to search for the device (and this would be our first time using wireshark). So, we decided to ask here first. We will be trying to install wireshark to see if we can find the CRio on another IP address as soon as possible.


My guess is that your firewall is blocking communication. Are you sure Windows firewall is completely disabled?

Yes - it is disabled…we triple checked this because it seemed a likely candidate :slight_smile:


I am not sure about exactly what happens, but when you reset a crio, doesn’t its ip address change? I think you need to change your computer ip to (I chose 8 because nothing uses it) and try to ping (That is a period, not an extra dot.) It would be because the subnet mask on the crio is masking the ip address of the computer, until you change it to have the same initial numbers in the ip address.

Thanks!! We will definitely try this today.

Having a similar problem although our cRIO (original model) does not lose communications with the laptop. It simply freezes on the “rebooting cRIO” message, while I can still ping the device or open it with ftp.

The image wipe is not working correctly, because the old robot code is still there along with some image files from last year. Maybe these files are causing problems. I’ll try to find some log information tonight.

Firewall disabled along with the wlan adapter.

I’ve left it in this state for ~1 hour hoping the avoid a watched pot issue, but no luck.

Walter, I had the same problem when initially updating my crio. I found the rebooting crio time to abnormally long. I got lucky in that when doing it, I went on here to see if anyone had problems (not yet when i was checking) and I came back 6 minutes later and it was updating again after the reboot. I ran into the same problem as you multiple times, it might just be patience. IFF (if an only if) it takes 15 minutes, force close the program and reboot the power to the crio (waiting 10 seconds after shutting off power before turning it back on) and try it again. I did this 6 times on one of my crios before it worked. Seems to be a bug in the image or imaging software.

If you are having difficulties imaging your cRIO, I would suggest going to and looking through the forums or contacting a support engineer.

Greg McKaskle

Here’s what worked for us:

  1. Put cRio in safe mode (hold reset button down for several seconds)
  2. Launch NI imaging tool - select appropriate radio button in “Development Environment” and “Format Controller” checkbox and click apply.
  3. A dialog box will pop up that says the cRio is in safe mode and cannot be imaged but gives the option to format. Click “format cRio”
  4. The “Reconfiguring Device” dialog box comes up and first says it is formatting (maybe 30sec) then rebooting (another 30sec).
  5. After the reboot completes, the same dialog box will indicate the format is complete.
  6. Power down the cRio, turn safe mode off (dip switch on 8 slot - power cycle for 4 slot), turn on cRio. NOTE: when you turn on the cRio, the status light will flash 2 times (repeating). This indicates the chassis has detected an error in its software. Not to worry.
  7. Click apply on the imaging tool - the “Reconfiguring Device” dialog box comes back up indicating it’s formatting (maybe 20sec) then rebooting (maybe 30sec).
  8. If all wen well it should then start re-imaging the cRio.

Thanks y’all.

I’ll try these suggestions tonight and if not successful will call NI.

We normally don’t start with these activities until week 6, so this is real progress.

We had the same issue. Using the old 2013 imaging tool, but putting the 2014 image file (.zip file) in C:\WindRiver\WPILib\cRIO_Images and selecting it in the FRC Imaging Tool resolved the issue.

My guess is that the 2014 Imaging tool is flawed or has a bug.

Yes. This has worked for us.

Also, you should try changing the ip of your computer (just in case you have the same address as the cRIO), and DISABLE ALL OTHER NETWORK ADAPTERS!! If you have wi-fi on, it doesn’t usually reconnect.

Also, if this doesn’t work, go to device manager, go to the settings for your network adapter, and turn off all power saving features.

Can you confirm that you’re following these steps:


Here’s some feedback: switching to Safe mode for an initial format took care of my problem. Thanks Dave and everyone else.

Onward in this great journey…