cRIO image error help

We are following the get started manual and have run into the following error when trying to image the cRIO right after step 8 under running the cRIO imaging tool.


Error 56 occurred at UDP Read in repFPC read packet.vi->SendRebootCmd.vi->RebootSystem.vi->Format Target.vi->ConfigUtility.lvlib:ReImageTarget.vi->ConfigUtility.lvlib:Dialog.vi

Possible reason(s):

LabVIEW: The network operation exceeded the user-specified or system time limit.

We could not find an answer on chief delphi, although we did try it both with and without a router. We are using a regular laptop, not the classmate for our development computer. Help.

Also, how do we reset the cRIO image, because we think it may be corrupted?

You can try turning on the Safe Mode DIP switch, power-cycle the cRIO, then run the Imaging tool to format it. After that’s complete, you turn the Safe Mode switch off and run the Imaging Tool again to install the image.

-Joe

Thanks for the help. We tried what you recommended and was still getting the same error. We did some searching and found several forum posts on the NI board that recommended trying it from another computer.

We used another computer and everything went perfect. I don’t know what the difference was, but it did work.

The cRIO’s Ethernet port is deactivated briefly a couple of times during the reimaging process. Some computers take longer than others to recognize when the connection is back, and the reimaging software times out if it takes too long. That might be what you’re seeing.

Or it might not be, since you mention having tried it with a router in the middle, which usually keeps the problem from happening. Whatever was going on, I’m glad you found a way around it.