cRIO Imaging Error


We are following the guide at and are encountering the following error when attempting to format the cRIO for Java with the image.

Unable to complete operation because of unexpected error 66:
TCP Read in NI_InternetTK_Common_VIs.lvlib:TCP Read xTP>NI_InternetTK_FTP_VIs.lvlib:FTP Get Command>NI_InternetTK_FTP_VIs.lvlib:FTP>NI_InternetTK_FTP_VIs.lvlib:FTP [QUIT].vi->NI_InternetTK_FTP_VIs.lvlib:FTP Close>NI_InternetTK_FTP_VIs.lvlib:FTP Get Multiple Files and>NI_InternetTK_FTP_VIs.lvlib:FTP Get>>>

We are using the Classmate (ip and are able to connect to and ping the cRIO.

I have tried to upload the BuiltInDefaultCode to the robot anyway, but encounter another error which leads me to believe that the cRIO imaging error is the cause.

Connecting FTP @
C:\Documents and Settings\Developer\sunspotfrcsdk\build.xml:95: The following error occurred while executing this line:
C:\Documents and Settings\Developer\sunspotfrcsdk\ant\upgrade.xml:40: Expected version Java; for Language but got Unknown;. Go to to get latest software update

Does anyone have any ideas on what we could try? Thanks.

Never mind, reformatting the cRIO in safe mode and then reimaging it worked. :slight_smile: