cRIO Imaging Failure

So my team just got our new compact cRIO and the last couple of days our programmer and I have been trying to reimage the cRIO. Trying unsuccessfully. So far we’ve tried crossover and ethernet cables to connect to our programming laptop to the cRIO, disabled all firewalls on it as well, used a dizzying array of different IP and subnet settings, and made sure all the modules were in the right slots and still it we are getting the same error. Probably the most annoying thing is that flashing takes about 20 minutes for it fail - I mean if its going to fail at least to it right off the bat so we dont have to waste our time waiting.

Unable to complete operation because of unexpected error:
Error 54 occurred at TCP Open Connection in NI_InternetTK_FTP_VIs.lvlib:FTP Open Data>NI_InternetTK_FTP_VIs.lvlib:FTP Data>NI_InternetTK_FTP_VIs.lvlib:FTP [STOR].vi->>>>>>

Possible reason(s):

LabVIEW: The network address is ill-formed. Make sure the address is in a valid format. For TCP/IP, the address can be either a machine name or an IP address in the form If this error occurs when specifying a machine name, make sure the machine name is valid. Try to ping the machine name. Check that you have a DNS server properly configured.

We can always switch out to our old cRIO but our lead mentor is hell bent on getting the new one to work for weight and size reasons. We are tearing our hair out right now - can someone PLEASE help.

Did you:

  • Connect your programming laptop to the DLink, then the DLink to the cRIO
  • Disable all other NICs (don’t just turn off wireless, actually go in and Disable it), so only the Ethernet port connected to the DLink is enabled.
  • Let the Driver Station application set your programming laptop’s IP address (it’ll do the right thing)
  • Keep your Firewalls and anti-virus turned off
    I suppose there’s the possibility of a corrupted installation.
    Have you tried from a different computer?

We are direct connecting our laptop to the cRIO. The D-Link is out of the picture for the moment. We also made sure to disable the W-LAN on our laptop.

Laptop ip is currently on a subnet (we did also try cRIO is on We also omitted our team number from the IP and just used 10.0.0.xx.

I’ll recheck the firewalls but im pretty sure both the Avast! and Windows firewalls are turned off.

Using FRC_2012_v43 image.

Add the DLink or another switch back into the picture.
Some laptops don’t react well to the changing cRIO IP address partway through the process and a switch or router maintains the connection.
The address changes twice as I recall.

Alright so we tried adding the D-Link back into the mix and that didnt fix anything. Still go the error 54. BUT…

We installed the LabView utilities onto our driver station laptop - an Asus Eee 1015. We know it has the right IP settings since it ran our Logomotion bot for demonstrations a few months back and hasnt been touched since. The cRIO flashed fully without error we got our robot moving by the end of the day. Just on a whim, we later compared the IP settings on our programming laptop with out our driver station and they were exactly the same. They are both running Windows 7 as well so IDK. I guess the computer was the issue.