cRIO Imaging Tool trouble

Whenever I try to put the new image on the cRIO, it’ll give me an error while it’s formatting. It said that the possible error was that it timed out while rebooting or something. Any ideas? Thanks.

Some laptops don’t handle the cRIO IP changes/reboot well.

It often helps to connect your laptop to the cRIO through a network switch rather than directly. The network switch remembers the connection to the cRIO longer before aging it out, lasting through a reboot, while some laptops see the cRIO disappear immediately and break off the connection right away.

Thanks! About how much would a network switch probably be, and where could I find one? I’m not too savvy with networking stuff.

You have one in the kit.

Ah. I feel silly. Thanks so much!

Just wondering, since I like to know the details of what is actually going on, is the ARP table time to live on switches higher than on computers? Does windows just clear the ARP table when a cable is unplugged? Or am I misinterpreting the switch remembering the cRIO as an ARP thing when it really isn’t?


If you keep getting timeout errors, go through the usual checklist of network settings. DISABLE all firewalls. DISABLE all network interfaces other than the one actually connecting to the cRIO. Don’t just disconnect them, or just turn off the WiFi. Make sure, of course, that your computer’s IP address is compatible with your team number.

As you know, a network switch maintains an ARP and ages out connections gracefully for efficency’s sake. Switches, routers, gateways, access points all have to be much more forgiving that a computer’s NIC, because they must deal with more simultaneous connections, and momentary (or longer) communication glitches are much more common. Devices connect and disconnect all the time, and switches also keep track of which network hops are likely to lead to twice-removed machines.

An individual computer’s NIC typically only talks directly to or through one other device, while a switch must maintain connections to dozens. The timeout on a switch or NIC depends on the manufacturer’s attitude towards who they consider their market, so some timeout quickly, while others are more forgiving and take longer.
Part of the reason for the quick-to-drop attitude may be the evolving nature of mobile devices that must be on the lookout to change APs rapidly to maintain the strongest network connection. Switches don’t roam as much as laptops do (except for those on our robots maybe).:slight_smile:

We are having the same problem and can’t get it to work. Any other ideas?

Only the ones already posted. Have you turned off the Windows firewall? Have you gone into the network configuration and disabled extra network adapters?

Tried all that. Still didn’t work. Switched to my computer and it worked. Must have been something about my dad’s computer

For the past few weeks we have been trying to get our robot from last year to work. The driverstation is giving us a greenlight for everything including robotcode. We think it’s a problem with the cRIO.

not a lot of information in your post to go on here !!

have you upgraded the cRio to version V43 ?

have you upgraded the imaging tool to the latest that came out a week ago ?

have you rearranged your modules to this years arrangements. If you haven’t then you will get just what you described.

Okay I think I’ve managed to upgrade to the latest imaging tool, but I every time I try to re-image it with v43 an error pops up. When we tried it said "Unable to complete operation because of unexpected error:
Error 56 occurred at TCP Open Connection in NI_InternetTK_FTP_VIs.lvlib:FTP Open Data>NI_InternetTK_FTP_VIs.lvlib:FTP Data>NI_InternetTK_FTP_VIs.lvlib:FTP [STOR].vi->>>>

Possible reason(s):

LabVIEW: The network operation exceeded the user-specified or system time limit."

If you search the Chief Delphi forums for that error, you will find many suggestions for how to proceed. The first one is to make sure you don’t have a Windows firewall active. The second one is to disable all network interfaces except the one you’re actually using to connect to the cRIO. The third one is to connect both the computer and the cRIO to the D-Link router instead of using a cable directly between them, though that usually gives a different error and should have been resolved in the most recent Imaging Tool.